Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Author Topic: Sparky Linux Game Over edition fails to boot on Socket 939 AMD X2 3800+  (Read 352 times)

Offline Skybuck

  • Newbie
  • *
  • Posts: 12

I did my best trying to install Sparky Linux Game Over edition from usb stick to same usb stick using rufus without old bios fix.

It worked on the toshiba laptop L670.

But trying to boot the same usb stick produces this boot screen error:

I also saw "grub" earily when it booted automatically without boot menu.

I am a total noob so not sure if I installed it correctly to begin with. I will make new thread to ask how to install it correctly with partitions and such cause it's quite complex seeing all the flag options.

Link to picture to show boot screen errors:

(Also the error message says to boot with a certain option and to send a bug report ? How exactly do I do that if at all possible ? Hmm ? Maybe some kind of option in tab if it gets that far, can't remember if this was before or after the menu came up, maybe before... could also be after :))

« Last Edit: November 11, 2019, 03:43:22 pm by Skybuck »

Offline Skybuck

  • Newbie
  • *
  • Posts: 12
Re: Sparky Linux Game Over edition fails to boot on Socket 939 AMD X2 3800+
« Reply #1 on: November 14, 2019, 03:33:10 pm »
*** updated ***:

This problem is solved by adding "noapic" to the boot options.

This can be done by entering the editor on boot time by pressing E:

The use right arrow on keyboard to navigate to the back of the line where it says something like:

Linux /boot  blablablabla.... noapic

(*** noapic must be written with small letters ***)

Press control-x to boot.

And this solves the error messages and will boot Sparky Linux just fine on Socket 939 motherboard and AMD X2 3800+ processor.

One last tip:

To install nvidia graphics card drivers go to terminal window after installer of spark linux is done and type:

sudo apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')

sudo apt-get install nvidia-settings nvidia-driver nvidia-opencl-common
or (for hybrid graphics chipset):
sudo dpkg --add-architecture i386 && sudo apt-get update && sudo apt-get install bumblebee-nvidia primus primus-libs:i386

This was illustrated in this video:

« Last Edit: November 14, 2019, 09:50:29 pm by Skybuck »