Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Issue installing live Live USB

Started by fragsrus, September 04, 2019, 01:40:36 AM

Previous topic - Next topic


I am running sparkylinux-2019.08-x86_64-gameover on a USB.  I can boot from the USB and access the OS without problem.  However, when I go to install onto a 2nd USB I run into issues.  Everything seems fine at first, it creates the partitions and moves on to "Filling up filesystems."  This is where the whole process stops.  I have tried it a few times now after some basic troubleshooting steps, i.e. re-creating boot USB, checking BIOS settings, moving Live USB to different USB port, and it always stops somewhere between 25-30%.  The system is not frozen.  I can still use the OS and the various information within the installer window keeps rolling.  However, eventually it kicks back an error that "./bootloader-eficonfig failed". 

Can anyone offer some advice?


Just to add some additional info, I am able to install perfectly fine to the installed HDD.  So this would suggest the Live USB is fine, both physically and digitally.  I am also able to use the target USB fine as a Live USB, so that would suggest there is nothing wrong with it as well.  So why would the install timeout when configuring the bootloader only when installing to another USB?


I finally got it working.  I ended up manually creating the partitions and then using the Advanced Installer.  It took well over an hour but it did complete.  It is interesting that the system runs so very slow on a USB key.  I installed is to the internal 5400 RPM HDD as well and that is actually much faster.  I would not have thought that running off an HDD would be faster than a USB.  I may try to pick up an SSD to through in there.  Now if only there was something I could go about the NVMe controller on a laptop.

Anyways, hope my struggles may help someone else.  I may take a look at Ubuntu's and Fedora's gaming distros as well to see how they compare.


Please mark as SOLVED if solved.

As noted above, usage of the advanced installer is second in my tools for installs that do not work.  Checksumming is first.

Memory has wildly different speeds and quality, your USB might be at the low end.  Also possibly there are bad portions that have to be worked around.  I have found that USB's sometimes go bad on me and that even the usage of "dd" will not fix.  I have 6 year old 16 or 32 GB SDHC's designed for fast access on cameras still performing on netbooks as the storage and comparable to the 120 Gb hdd on the one netbook.  And a new SSD from crucial on a 4 year old motherboard - much improved.  Higher quality memory.

A rescue USB and possibly a USB for more private browsing (TAILS, etc) are about the only uses I can come up with for using a USB for the OS on a steady basis. Oh wait, clearing up trojans and crap on Windows installs of friends computers.  I am not aware of the present status of AVG Linux. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum