Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: incorrect entry for swap in /etc/fstab  (Read 1707 times)

Offline CaptZapp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
incorrect entry for swap in /etc/fstab
« on: August 20, 2019, 04:15:01 am »
Installed this evening using the 2019.08 GameOver Edition iso. Everything went well, though I noticed that boot times were very long after installation. After investigating, I noticed that the fstab had an entry for swap. I didn't create a swap during install, however, and the entry in /etc/fstab was:

UUID=                                     swap           swap    defaults,noatime 0 2

Apparently the installer got a bit confused with my option not to use swap. Commented out that line and now everything is working flawlessly; boots in 4 seconds :)

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2289
  • Karma: 7
    • SparkyLinux
Re: incorrect entry for swap in /etc/fstab
« Reply #1 on: August 20, 2019, 12:34:50 pm »
What installer have you used?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Offline CaptZapp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: incorrect entry for swap in /etc/fstab
« Reply #2 on: August 20, 2019, 04:27:45 pm »
IIRC it was a Calamares, that I launched using an icon on the left side of the desktop.

Offline CaptZapp

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: incorrect entry for swap in /etc/fstab
« Reply #3 on: August 21, 2019, 12:19:28 am »
This is definitely a bug in Calamares itself rather than specific to SparkyLinux. I installed EndeavourOS today and had exactly the same issue. I'll check the Calamares. It doesn't seem that this has been reported on their page, so I'll report over there.