Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

<SOLVED>I have an issue with ndiswrapper.

Started by kreitzer, August 12, 2019, 04:36:36 AM

Previous topic - Next topic


I tried ndiswrapper on a couple of distros before and my wireless card goes better, especially with a weak connection.

But in sparky is not working. I just installed and updated SparkyGameOver ed. And when I installed ndiswrapper I realized that it doesn't work.

~$ ndiswrapper -v
modinfo: ERROR: Module ndiswrapper not found.
module version is too old!
utils version: '1.9', utils version needed by module: '0'
module details:
modinfo: ERROR: Module ndiswrapper not found.

You may need to upgrade driver and/or utils to latest versions available at

I downloaded ndiswrapper source and I couldn't install it either.

:/usr/src/modules/ndiswrapper$ sudo make
[sudo] password for sparky:
Makefile:32: *** No .config found in /usr/lib/modules/4.19.0-5-amd64/build, please set KBUILD to configured kernel.  Stop.

Is there a way to fix it easily? Thanks in advance.


Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//"][/url]


I'd skimmed through the page a few times before. But what I didn't know was that I had to install a module manually. I'm still very new to linux.

Anyway, thank you very much for your help.

This is what I had to do:

apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') ndiswrapper-utils-1.9 wireless-tools

View the most recent posts on the forum