Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: I broke it, can somebody help me fix it??  (Read 2869 times)

Offline xendistar

  • Newbie
  • *
  • Posts: 36
  • Karma: 0
I broke it, can somebody help me fix it??
« on: August 06, 2019, 09:48:26 pm »

I have just installed the latest rolling semi rolling install with the xfce desktop.

I was trying to get the appearance, colour, font just to my liking and now I have a hideous monster. I have windows with no button in the top left corner (minimise, expand & close) or right corner. (context menu??). I can not click on the toolbar to move windows around, very annoying when you have two screen and everything opens on the smaller laptop screen.

Can somebody please tell how I can get the window controls back again please?

Offline manyroads

  • Newbie
  • *
  • Posts: 44
  • Karma: 0
    • ManyRoads
Re: I broke it, can somebody help me fix it??
« Reply #1 on: August 06, 2019, 10:02:21 pm »
Sounds like you broke your theme.  Try changing themes to see if that fixes it.  You can try a reboot first if you have not already done that. 
dwm & i3wm ~Reg. Linux User #449130

Offline xendistar

  • Newbie
  • *
  • Posts: 36
  • Karma: 0
Re: I broke it, can somebody help me fix it??
« Reply #2 on: August 06, 2019, 10:19:57 pm »

Played a round with the themes and rebooted, make no difference.

Also found that when I click on any of the windows menus, I can not use the mouse to click the option I want, as soon as I move the mouse the menu will close, I have to open the menu with the cursor and then use the up and down arrows to select the option I want.

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 855
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: I broke it, can somebody help me fix it??
« Reply #3 on: August 06, 2019, 10:53:48 pm »
Not that I do it, but many encourage people to have a little paper notebook to write down changes that they do as they do it.  If you were making changes via the XFCE gui, they should all be reversable.  Should. 

Wait and see what others say, but if you decide to rip out XFCE and put it back in the program tasksel  (Debian program) would do that for you and probably not doing any damage to your data.  I will be ripping out KDE and returning to LXQt via tasksel in the semi-near future  on my main, stable computer.  peace out.  Or you could remove probably via the proper meta-package.  But wait.

 It never hurts to post the output from a terminal of the command

"inxi -Fr"  onto your post, formatted as code (the # button)



Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline xendistar

  • Newbie
  • *
  • Posts: 36
  • Karma: 0
Re: I broke it, can somebody help me fix it??
« Reply #4 on: August 06, 2019, 11:31:13 pm »
Here you go

Code: [Select]
System:
  Host: spark Kernel: 4.19.0-5-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.4
  Distro: SparkyLinux 6 (Po-Tolo)
Machine:
  Type: Laptop System: LENOVO product: 24296JG v: ThinkPad T530
  serial: <root required>
  Mobo: LENOVO model: 24296JG v: Win8 Pro DPK TPG serial: <root required>
  UEFI [Legacy]: LENOVO v: G4ETB2WW (2.72 ) date: 04/10/2018
Battery:
  ID-1: BAT0 charge: 78.0 Wh condition: 79.2/93.6 Wh (85%)
CPU:
  Topology: Quad Core model: Intel Core i7-3630QM bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 1222 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 1197 2: 1424
  3: 1213 4: 1199 5: 1204 6: 1196 7: 1246 8: 1197
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: NVIDIA GF108M [NVS 5400M] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
  resolution: 1600x900~60Hz, 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.1.2
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.19.0-5-amd64
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 3c:97:0e:a2:0f:e8
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
  IF: wlan0 state: down mac: a2:64:c8:6d:50:70
  Device-3: Ericsson Business Mobile Networks BV H5321 gw Mobile Broadband
  Driver
  type: USB driver: cdc_acm,cdc_ncm,cdc_wdm
  IF: wwan0 state: down mac: 02:15:e0:ec:01:00
Drives:
  Local Storage: total: 1.36 TiB used: 128.80 GiB (9.2%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS725050A7E630
  size: 465.76 GiB
  ID-2: /dev/sdb type: USB vendor: Seagate model: Ultra Slim PL
  size: 931.51 GiB
Partition:
  ID-1: / size: 44.87 GiB used: 4.28 GiB (9.5%) fs: ext4 dev: /dev/sda1
  ID-2: /home size: 383.49 GiB used: 560.7 MiB (0.1%) fs: ext4
  dev: /dev/sda2
  ID-3: swap-1 size: 29.30 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: nouveau temp: 40 C
  Fan Speeds (RPM): cpu: 1974
Repos:
  Active apt repos in: /etc/apt/sources.list
  1: deb http://deb.debian.org/debian/ testing main contrib non-free
  2: deb-src http://deb.debian.org/debian/ testing main contrib non-free
  3: deb http://deb.debian.org/debian-security/ testing-security/updates main contrib non-free
  4: deb-src http://deb.debian.org/debian-security/ testing-security/updates main contrib non-free
  5: deb http://www.deb-multimedia.org/ testing main non-free
  No active apt repos in: /etc/apt/sources.list.d/dropbox.list
  No active apt repos in: /etc/apt/sources.list.d/liquorix.list
  Active apt repos in: /etc/apt/sources.list.d/sparky-testing.list
  1: deb https://sparkylinux.org/repo/ core main
  2: deb-src https://sparkylinux.org/repo/ core main
  3: deb https://sparkylinux.org/repo/ testing main
  4: deb-src https://sparkylinux.org/repo/ testing main
  Active apt repos in: /etc/apt/sources.list.d/sparky-unstable.list
  1: deb https://sparkylinux.org/repo/ unstable main
  2: deb-src https://sparkylinux.org/repo/ unstable main
Info:
  Processes: 218 Uptime: 1h 14m Memory: 7.48 GiB used: 997.2 MiB (13.0%)
  Shell: bash inxi: 3.0.35
mit@spark:~$

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 855
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: I broke it, can somebody help me fix it??
« Reply #5 on: August 07, 2019, 05:03:53 am »
Via looking at https://packages.debian.org/bullseye/xfce4  I can see the xfce4 (the meta-pckage) has been quiet - 4.12.3 in old stable and 4.12.5 in buster (stable), bullseye (testing where you are) and sid.      I have not heard a lot of problems with  the base of XFCE.  Very stable platform. 

Thanks for the inxi.

You have a sane set of repositories.  Your computer is running a little hot, but not excessively.  You are sitting on a good kernel, you do not need a newer kernel on an older machine usually.    You might have to investigate hardware versus software.  (For myself, the 10 y.o. netbook stopped autocompleteing  - I investigated  bash.rc, not there - it is the 10 year  keyboards failing tab hey -  hardware)

If you review (for yourself if no one else)  what were your goals to modify XFCE and how you tried to do it (command line or gui)  , what part of system preferences did you work with. 

Have you tried another mouse?  Is your track pointer messing with your mouse?  Do your problems start immediately or after your computer warms up? 

tasksel is a little finicky.  I would prefer to run it myself again before giving advice on it's usage.  Hopefully people who use XFCE will step up and assist here.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline xendistar

  • Newbie
  • *
  • Posts: 36
  • Karma: 0
Re: I broke it, can somebody help me fix it??
« Reply #6 on: August 07, 2019, 05:44:36 pm »
Hi Paxmark1

I noticed that the fonts were block and not particularly smooth so I was playing with appearance and fonts. I guess somewhere down the road I pushed the wrong button and hey presto I am where I am now.

This is a fairly new install (4 days) so I am simply going to wipe the disk and start again. Thanks for the advice I shall be back later.

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 855
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: I broke it, can somebody help me fix it??
« Reply #7 on: August 07, 2019, 06:50:04 pm »
well tasksel  would keep your basic system still up  tasksel is a ncurses program, the step below a gui that looked like the cats pyjamas back with intel 286 chips. 

This is a win - win for me to research this as I explained above about KDE and me. 

If you believe you misconfigured /fonts or settings for fonts, maybe re-install

https://wiki.debian.org/tasksel

http://www.pc-freak.net/blog/debian-linux-remove-xorg-gnome-gdm-graphical-environment-packages-serverr/

Good info, not too dated    you would want to do this from a virtual terminal (virt tty) - acessed via Ctl-Alt-F2   (or F3 or ...   )  Once you have it see if you get back to your
GUI via Ctl-Alt-F7   there have been changes away from the standard Alt-F7  on some GUI's. 

As root  in the virtual terminal     (or as a user use sudo tasksel remove desktop)
Code: [Select]
tasksel remove desktop
And then use tasksel and check off LXDE print server and SSH server (and probably laptop) to reinstall. 

If you have data BACKup.

I will be doing this myself in the near future, but if you are going towards a re-install, you don't have much to lose via doing this first.   





sudo tasksel -t        ###   Checking the Debian desktop environment will pull in Gnome  I would uncheck

Code: [Select]
*] Debian desktop environment     
                                         │    [*] Debian desktop environment
                                         │    [ ] ... GNOME                                                                            │
                                         │    [ ] ... Xfce                                                                             │
                                         │    [*] ... KDE Plasma                                                                       │
                                         │    [ ] ... Cinnamon                                                                         │
                                         │    [ ] ... MATE                                                                             │
                                         │    [ ] ... LXDE                                                                             │
                                         │    [ ] ... LXQt                                                                             │
                                         │    [ ] web server                                                                           │
                                         │    [*] print server                                                                         │
                                         │    [*] SSH server                                                                           │
                                         │    [ ] laptop   
« Last Edit: August 07, 2019, 06:53:05 pm by paxmark1 »
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline xendistar

  • Newbie
  • *
  • Posts: 36
  • Karma: 0
Re: I broke it, can somebody help me fix it??
« Reply #8 on: August 07, 2019, 09:12:10 pm »
Unfortunately within a couple of minutes of my last post I rebooted to the install usb stick and reinstalled. As this is my main machine I wanted to be back up and running, had it been an older PC then I might of had a play (although I do have two other running PC that I could of worked from plus a large pile of bits that would make another PC if required).

I will try not to break my Laptop this time (famous last words)