Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

problem upgrading to sparky5

Started by f, September 25, 2019, 11:14:28 PM

Previous topic - Next topic


Hello, I was using Sparky 4 for a while (with lxde), and I really like it!, so congratulations for your work!

Well, today I decided to upgrade from Sparky 4 (oldstable, debian 9 based) to Sparky 5 (stable, debian 10 based), and have some trouble that can't fix alone, so... I'm going to tell you, the best I can, what happened.

So, I did a common upgrade on the oldstable system first, and then follow the instructions on
Everything was going well.. I change the repos as explained, correctly install sparky5-apt, correctly do update, and finally do full-upgrade.
Everything looks good, but at the end of the full-upgrade, it displays something like

Tal vez quiera ejecutar «apt --fix-broken install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
gstreamer1.0-gl : Depende: libgstreamer-gl1.0-0 (>= 1.14.4) pero no está instalado
libwebkit2gtk-4.0-37 : Depende: libgstreamer-gl1.0-0 (>= 1.14.0) pero no está instalado
libwebkit2gtk-4.0-37-gtk2 : Depende: libgstreamer-gl1.0-0 (>= 1.14.0) pero no está instalado
E: Dependencias incumplidas. Intente «apt --fix-broken install» sin paquetes (o especifique una solución).

Ok, after that, i do sudo apt install -f (or sudo apt-get install -f), or apt --fix-broken install and all of that end essentially with the same result:

chaja@chaja-pc:~$ sudo apt-get install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  apt-transport-https dh-python fonts-texgyre gnupg-agent libass5
  libattr1:i386 libblas-common libboost-filesystem1.62.0
  libboost-iostreams1.62.0 libboost-system1.62.0 libck-connector0
  libfile-copy-recursive-perl libgfortran3 libgltf-0.0-0v5
  libgstreamer-plugins-bad1.0-0 liblivemedia57 liblzma5:i386 liborcus-0.11-0
  libpcre16-3 libpcre3:i386 libpostproc54 libprotobuf-lite10 libqt5clucene5
  libqt5opengl5 libsasl2-modules libselinux1:i386 libsndio6.1 libupnp6
  libuuid1:i386 libva-wayland1 libx264-148 libx265-95 python3-distutils
  python3-lib2to3 python3.5 python3.5-minimal rename vlc-plugin-notify
  vlc-plugin-samba vlc-plugin-video-splitter vlc-plugin-visualization
Utilice «sudo apt autoremove» para eliminarlos.
Se instalarán los siguientes paquetes adicionales:
Se instalarán los siguientes paquetes NUEVOS:
0 actualizados, 1 nuevos se instalarán, 0 para eliminar y 1042 no actualizados.
407 no instalados del todo o eliminados.
Se necesita descargar 0 B/1.353 kB de archivos.
Se utilizarán 1.694 kB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n] S
/usr/share/apt-listchanges/ FutureWarning: Possible nested set at position 25
  email_re = re.compile(r'([a-zA-Z0-9_\+\-\.]+)@(([[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([a-zA-Z0-9\-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)')
(Leyendo la base de datos ... 230992 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../libgstreamer-gl1.0-0_1.14.4-2_amd64.deb ...
Desempaquetando libgstreamer-gl1.0-0:amd64 (1.14.4-2) ...
dpkg: error al procesar el archivo /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_amd64.deb (--unpack):
intentando sobreescribir `/usr/lib/x86_64-linux-gnu/', que está también en el paquete libgstreamer-plugins-bad1.0-0:amd64 1:1.10.4-dmo2
Se encontraron errores al procesar:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Even when I do "sudo apt autoremove", it shows the same without doing anything.
After this, I reboot the machine (that luckily remains usable!), treat again, but is the same result..

Something that catches my attention is that when I look for the Linux version after reboot, it remains at 4.9.0 (according to what i understand it should show 4.19), or when I put lsb_release -a it shows that it is still on Sparky 4.

So... I guess the concrete problem with this is that I can't upgrade the system anymore.

Any help would be appreciated, regards!!

View the most recent posts on the forum