Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Calamares Install Fails

Started by pkmorrison, July 13, 2019, 02:24:46 PM

Previous topic - Next topic

pkmorrison

This is from lxqt 5.7.1 iso:

Boost.Python error in job "packages".
Command 'apt-get update' returned non-zero exit status 100.
Ign:1 http://security.debian.org testing/updates InRelease Err:2 http://security.debian.org testing/updates Release 404 Not Found [IP: 151.101.184.204 80] Hit:3 http://ftp.debian.org/debian testing InRelease Hit:4 https://sparkylinux.org/repo core InRelease Hit:5 https://sparkylinux.org/repo testing InRelease Reading package lists... E: The repository 'http://security.debian.org testing/updates Release' does not have a Release file.

Traceback:
File "/usr/lib/x86_64-linux-gnu/calamares/modules/packages/main.py", line 515, in run
    pkgman.update_db()

  File "/usr/lib/x86_64-linux-gnu/calamares/modules/packages/main.py", line 267, in update_db
    check_target_env_call(["apt-get", "update"])

  File "<string>", line 11, in <module>

lami07

#1
Grab 5.8 RC ISO from here:
https://sourceforge.net/projects/sparkylinux/files/testing/
Or wait few more days for next Sparky release.

If you decide to go with 5.8 RC read this:
https://sparkylinux.org/sparky-5-transition/
Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//irc.freenode.net"]irc.freenode.net[/url]

pkmorrison

#2
Got the 5.8 RC as advised - still no luck.

https://ibb.co/f2Zh6q6

Will wait for the next release.

pavroo

Unfortunately the 5.7.1 & 5.8 RC uses old Debian repos, which are not in use any more.

You can use Sparky Advanced installer which does not upgrade the package list, even uses old Debian's repo (if you do not try to install other desktop via Minimal ISO). So, if you install the system as it is, via the Advanced installer, the error you got, will not break your installation.

Anyway, new 5.8 iso images are on the way, should be ready next week.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum