Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Sparky only boots to terminal --initramfs - SOLVED

Started by bushy, May 13, 2019, 09:07:30 PM

Previous topic - Next topic


I installed SparkyLinux 4.10 LXDE 32bit (i686 non-pae) On a lenovo 110s-11ibr it co-exists with Win10 & Lubuntu
When the normal boot failed I tried booting the recovery option w/o success.

Win10 and Sparky share a 120g NVMe ssd, Lubuntu is on 29g of eMMC memory.  Lubuntu was installed first and works OK, Sparky installation seemed OK, Grub shows all three OS's

Here's some info on my system
~$ inxi  CPU: Dual Core Intel Celeron N3060 (-MCP-) speed/min/max: 480/480/2480 MHz Kernel: 4.18.0-18-generic x86_64
Up: 9m Mem: 424.3/1841.9 MiB (23.0%) Storage: 140.92 GiB (7.5% used) Procs: 157 Shell: bash 4.4.19 inxi: 3.0.24

~$ inxi -D  Drives:    Local Storage: total: 140.92 GiB used: 10.59 GiB (7.5%)
           ID-1: /dev/mmcblk0 model: HBG4e size: 29.12 GiB
           ID-2: /dev/sda vendor: TCSunBow model: N8 120GB size: 111.79 GiB


yeah, that sounds pretty bad. 

it sounds like you've booted into Lubuntu.  you should be able to check out the sparky paritions pretty easily.   can you pastebin the /etc/fstab of both Lubuntu and sparkylinux?  also I'll probably ask you to fsck the partitions next.

cheers Bushy. 


I reformatted the the Sparky partition and re-installed Sparky to it.  Still fail to boot properly, it ends in a terminal.  The message this time is that it cannot find a UUID that doesn't exist. 

fstab from Lubuntu:
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=966F-1F1E                            /boot/efi      vfat    defaults   0 2
UUID=b395c868-35d4-41e2-86dc-9c074da2f305 /              ext4    defaults   0 1
UUID=09af5015-f67a-4cbf-bab5-24c2177c87c7 swap           swap    defaults   0 2

fstab from Sparky:
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=a8a7a7d8-2b2d-4f8a-976b-f052bcbc0cbb /              ext4    defaults,noatime,discard 0 1
UUID=09af5015-f67a-4cbf-bab5-24c2177c87c7 swap           swap    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0


Output of BLKID:
/dev/mmcblk0p1: UUID="966F-1F1E" TYPE="vfat" PARTUUID="eae94bea-1b07-4a2a-bf9e-ca53ce5b9aab"
/dev/mmcblk0p2: UUID="b395c868-35d4-41e2-86dc-9c074da2f305" TYPE="ext4" PARTLABEL="Lubuntu" PARTUUID="58fa046d-8089-4302-8945-9a8c285d4109"
/dev/mmcblk0p3: UUID="09af5015-f67a-4cbf-bab5-24c2177c87c7" TYPE="swap" PARTUUID="fd7aa125-75a9-4815-aee9-8b564514b2ea"
/dev/sda1: UUID="4092e7a6-89ae-4664-b319-9353ae389c30" TYPE="ext4" PARTLABEL="Microsoft reserved partition" PARTUUID="30acd1f3-e326-4a8b-944d-376ed3ff0380"
/dev/sda2: UUID="1CA86F9CA86F72E6" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="ec635cf5-caea-41ce-8f1e-aba0a979b291"
/dev/sda3: UUID="a8a7a7d8-2b2d-4f8a-976b-f052bcbc0cbb" TYPE="ext4" PARTLABEL="Sparky" PARTUUID="fed13ac5-09b7-4f06-8d51-763d88881452"
/dev/sda4: UUID="36184AEB184AA9A7" TYPE="ntfs" PARTUUID="c4e09019-38ef-4ea0-8b60-f63c55fed72d"
/dev/mmcblk0: PTUUID="63971ccd-c72b-4854-ada1-03681d206e20" PTTYPE="gpt"


I edited grub menu to replace the bad UUID with the correct one from blkid.  Removed "no splash" so I could watch the text based boot andit failed with the same problem, the corrected UUID does not exist.

Is this a problem with grub or Sparky?  Could it be a remnant of a bad installation?


Quotefstab from Sparky:
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=a8a7a7d8-2b2d-4f8a-976b-f052bcbc0cbb /              ext4    defaults,noatime,discard 0 1
UUID=09af5015-f67a-4cbf-bab5-24c2177c87c7 swap           swap    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
EFI partition is missing, you can not boot Sparky for sure.
Are you sure you have boot Sparky in UEFI mode?
The best way to find out is running the Sparky live again and run in a terminal emulator:
lsmod | grep efi
BIOS mode if output is empty.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


@bushy. For sure you have EFI activated from Bios. Deactivate it (leave it as legacy mode) and try to re-install Sparky. During installing process, on the last phase, the Calamares for sure have warned you that EFI partition is missing.

Solution is explained on this forum but also by Calamares installer (on the last phase - did you not noticed the dialog box that warned about EFI and missing of FAT32 partition ?).

Create a small (at least 100 MB) partition FAT32 (use Gparted). Change the flag of this partition to ESP. During the last moment of installing processes, when you are asked for : / and home locations also click on the famous ESP partition and chose /boot/esp is this partition. Actually I am far way from my Sparky machine to give you much more explanation. - explanations within this forum about EFI install
. or in the Sparky WIKI .

Also ...

@pavroo . Seems that

The Live Installer (Tyche 4) is  different form Calamares or not ? Why do not use this Live Installer on Sparky Test version ?

There is a possibility here .... Do not Install Grub . Much more convenient than Calamares in my opinion.


@pavroo. During the last week I have tried to install Sparky testing in one of my machines(laptops). This laptop is locked on BIOS and for sure EFI is enabled. So, I cannot change the EFI to legacy mode. I have tried but I did not arrive to install even I created a 100 gb of FAT32 partition. Calamares gaves me error (maybe because partition that I created as FAT32 was logical and located on the end of my partitions). I am aware about this. I get a lot of experience from my tests and I know to deal on my case.

The right way to install Sparky in the above mentioned laptop  or in other laptops with EFI activated is : or to disable EFI or when this in not possible > dismount you SSD or HDD and attach to another laptop similar with your laptop or desktop that has not EFI enabled and install Sparky. After installing  you can transfer Sparky in another laptop or desktop: by image,using RSync, Sparky backup ( or any other method - I can advice one for that ) . 

I tried also the Advanced Installer (that needs to be tested by others, because has bugs).

The Advanced Installer asked for Swap partition during install ( as I understood the Installer is not valid when you have no any Swap partitions). I am not very sure if Advanced Installer gives you the possibility to DO not Install Grub Loader ( leave untouched, because I was not able to arrive to this step. What I have noticed using Advanced Installer,was that even you click on Cancel button, Advanced Installer passes to the next step and the only way to stop installing process was to close it.

If it is possible to correct the Advanced Installer the follow things :

1- Make it responsible when you click on Cancel button ( Cancel means Leave Installer )
2- If Swap is not in the system do not ask for it and let installing process to continue.
3- Give the possibility to Do not install Grub ( leave boot loader untouched).

MX Linux has a very good installer (Gazele Installer) that gives you option to chose the place to install or even not install boot loader.

I know that Calamares has not the option Do not Install Grub when detects that EFI is activated from BIOS.( I searched for it in the google ). I am not very sure, how I  have arrived to install Sparky times ago ( but on the originally machine I had not EFI or EFI was not enabled). Since my original Sparky install, times and times ago, I transfer my Sparky to other laptops or as image or by using qt4-fstarchiver and I launch grub to detect it.

Would be worthy if you prepare a small utility in YAD (within Sparky , that someone can substitute or install the original Sparky configuration loader to be used by Grub that is installed in other partitions).This small utility will be worthy also to help one to reinstall grub .

I use way explained on the follow link   to reinstall or repair grub from my MX Linux usb bootable usb (or any Debian/Ubuntu ditro)
But i discovered that would be more correct if one use :
Quotegrub-install --target=i386-pc /dev/sdX
to install grub
Some explanations are here for grub 64 or 386 .



I do have an efi partition, it is on /dev/mmcblk0p1, this is the soldered 29g of eMMC storage. Sparky was installed on /dev/sda3 which is an added 120g M.2 SSD. BIOS was and is setup in Legacy mode.
@PAVROO  lsmod | grep efi comes back empty
I appreciate all the links, I will do some reading.


If your efi partition is encrypted, Sparky doesn't have chance to read or use it, in my way.
If you do not install Sparky on an encrypted disk/partition, post install script removes cryptsetup packages from the target system.
So I think that is your problem.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I don't believe the EFI partition is encrypted.  Inspecting the partition using gparted doesn't show me anything suggesting it is encrypted, is there some way to prove it isn't?
From blkid of the efi partition: /dev/mmcblk0p1: UUID="966F-1F1E" TYPE="vfat" PARTUUID="eae94bea-1b07-4a2a-bf9e-ca53ce5b9aab"  I expect there would be something on this line as a result of encryption.


Read the post:
and the line can be important:
QuoteThat's likely due to /boot/cmdline.txt which contains...
Hope will help.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


So Sparky now works well, I don't understand why but here's how it resolved itself.
I deleted the existing Sparky partition SDB3 and re-installed.  I once the installation started it completed on its own without any further dialogue or intervention never giving me an opportunity to do anything about GRUB or anything else about the boot process.  After installation the same failure to boot occurred.  I tried doing the exact same thing another time, same experience with the installation process.  This time however after doing a reboot Sparky worked perfectly.

So I have no idea what it ultimately worked or why the installation didn't mention anything about grub, efi or anything else but it works, it did a full upgrade and continues to work.

View the most recent posts on the forum