Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[SOLVED]systemd is waiting 90s for lxqt-session to stop?

Started by kanliot, May 22, 2019, 05:32:54 PM

Previous topic - Next topic


I'm used to just rebooting this pc by typing "reboot"

However, now lxqt-session seems to be not exiting if there are open applications on sparky-rolling.    I strongly disagree with this change, since it it  means I can do less things from the terminal.

Basically, it means you type reboot, then watch systemd wait for 90s for something to exit.

Please I would like advise on how to properly report this problem.
Thank you.


Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//"][/url]


To be able to see what is the hang up you could look at the tail end of your systemd journal for previous session.  You might need tail -300 or more.

sudo jourrnalctl -b -1 | tail -150                ## or
sudo journalctl -b -1 | tail -300 | less

If it is a bug in lxqt-session  - I don't see one filed upstream.

Pretty quiet in lxqt-session development I don't see many changes in lxqt-session

peace out and off to work

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


1. journald logging wasn't working, i had to create /var/log/journal to make the logs persistent.
2. the problem seems dependent on which websites I visit, If i just have firefox open it actually does reboot
3. the one time i tried systemctl restart, that worked also

QuoteOne of "volatile", "persistent", "auto" and "none". If "volatile", journal log data will be stored only in memory, i.e. below the /run/log/journal hierarchy (which is created if needed). If "persistent", data will be stored preferably on disk, i.e. below the /var/log/journal hierarchy (which is created if needed), with a fallback to /run/log/journal (which is created if needed), during early boot and if the disk is not writable. "auto" is similar to "persistent" but the directory /var/log/journal is not created if needed, so that its existence controls where log data goes.
^ Just including this because I'm in a bad temper.  Now you have to read it too.

you can see that it takes 89s not 90s between the first 2 lines and the rest

May 23 12:39:11 maleday dbus-daemon[689]: [system] Activation via systemd failed for unit 'rtkit-daemon.service': Refusing activation, D-Bus is shutting down.
May 23 12:39:11 maleday systemd[869]: Started Sound Service.
May 23 12:40:40 maleday systemd[1]: session-1.scope: Stopping timed out. Killing.
May 23 12:40:40 maleday systemd[1]: session-1.scope: Killing process 944 (lxqt-panel) with signal SIGKILL.
May 23 12:40:40 maleday systemd[1]: session-1.scope: Failed with result 'timeout'.
May 23 12:40:40 maleday systemd[1]: Stopped Session 1 of user kanliot.
May 23 12:40:40 maleday systemd[1]: Stopping Login Service...
May 23 12:40:40 maleday systemd[1]: Stopping User Manager for UID 1000...
May 23 12:40:40 maleday systemd-logind[706]: Removed session 1.
May 23 12:40:40 maleday systemd[869]: Stopping Virtual filesystem service - digital camera monitor...
May 23 12:40:40 maleday systemd[869]: Stopping Virtual filesystem service - Apple File Conduit monitor...

Gonna have a smoke then I'll take a look at my dpkg log.  I know exactly when the problem started so...I can make progress there.
BTW, how do you download old versions of sparky packages, and get both  versions of the source code?


Ok, had a vape and that fixed everything.

I figured out that it wasn't what webpage I had open, it was that any kind of app opened through lxpanel (i hardly use lxpanel) causes the problem.

thansk for the help lami07 and paxmark1.

if you please, suggest improvements to the bug I filed, I'm about 70% sure I identified the problem.

View the most recent posts on the forum