Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Sparky Linux Kernel 5.1.0

Started by wolfomat, May 06, 2019, 08:37:36 PM

Previous topic - Next topic

wolfomat

Hello there,

after upgrading my sparky linux gameover edition to 5.1.0 i've got a blackscreen.
so, i though i could re-install the nvidia driver again - 418.43. But I've got an error message.
thing is, i can' access my linux partition from this windows 10 installation, but the rror is shown in the screenshot (see attachment).

any ideas on how i can fix this - i don't want to use windows heeelp  :o
see: https://pasteboard.co/IdtQkvR.jpg

pavroo

It is really fresh kernel, I recommend to still use an older one.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Sergio 1

I have also a problem with the new 5.1 kernel - after installation, all the settings of the nvidia, sound, screen - flew to hell and do not react to anything. Thank God that there is an additional function in GRUB that includes previous kernels.

wolfomat

#3
Damn it i think apt autoremove deleted the old headers, can i apt-gwet the older versions and Boot from grub? Or are they still available hmm

Update: i've found in the grub options the kernel 5.0.12, which is nice. and i am now booting from this one....
Is this a sparkylinux issue ? however, from the terminal i could perfom sudo apt-get update and sudo apt-get dist-upgrade when it is fixed then, correct?

paxmark1


No, it is very definitely not a Sparky issue.  Nivida's nigh non-existent support of free software (FOSS) is a crucial part of the difficulties of getting as much out of newer Nvidia cards without errors and segfaults.  This is the case from Redhat-Fedora to Gentoo and everything in between.

First and foremost, if you are committed to Open source software and desire strong performing graphics cards, go AMD and their version of the ATI cards, they support Free soft ware much better.  But if you bought this before you got into linux, there is not much you can do. 

Imagine you are a performer in a circus, a high wire act. You are constantly forced to keep using new binaries of dark blobs of Nvidia binaries, you have no choice but to trust and pray they work - and Nvidia cares not one bit about you, for they are Windows and Mac dominated. And they keep coming out with new versions.  The other thing that puts you on the edge of the high wire is that the new kernel versions need to have time to work the new modules from Nvidia into the mix.  It is experienced users who can use the command line  who run Nvidia that write bug reports that get that fixed.  You also see these issues in certain Realtek binaries, one specific example is the Gordboy git for an example.  He has to keep updating his compilation of that crappy code for each kernel bump.  Search Realtek on this site or elswhere.  http://sparkylinux.org/forum/index.php/topic,4784.msg12325.html#msg12325     and others. 

Other forums that are cutting edge Debian will caution the usage of autoremove especially when you are way far up the testing rung of the kernel and have binaries that are not open source.  Those forums and irc will talk about the testers on the edge having to "pick arrows out"  and that staying a step or two back behind Sid-unstabe and especially experimental will be a much smoother experience. 

A close reading of the Debian wiki on Nvidia is always helpful, but usually outdated.  A close reading of the Arch Wiki on Nvidia also, but Arch is not a Debian derivative, be careful what you take.  And you can find the Nvidia forum listed on both of those. 

Having had to use Catalyst (AMD-Ati bianries) on a Sid machine (AMD C-50 cpyu/gpu) , I was so happy the day I could convert to radeon.  Multiply that times 3 (possibly) for the difficulty and 2 times the wait for being able to transfer from Nvidia to nouveau to receive all the features that are available from the beginning on Windows and Mac machines. 

It is not fair, but it is what it is.  Nvidia and Realtek do not support open source.



Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

pavroo

5.0.14 landed in Sparky repos to keep supporting the 5.0.x line too.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

wolfomat

#6
yeah i've got nvidia graphics way before i switched to linux.
i think i'll just install nueovoue, it should run most non-3d games great i think ^.^

... okay, i'm back on nouveau. the bad thing is i can't play borderlands2 :D either i get in 2-3yrs an ati gfx or i boot into windows for gaming (except for nice 2d games like factorio...running on nouveau fine, too..)

View the most recent posts on the forum