Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

SOLVED Problems with a dot matrix printer

Started by Sy41CL, April 14, 2019, 01:50:32 PM

Previous topic - Next topic

Sy41CL

Hi, I use a dot matrix printer Lexmark 2491. In my very great number of Linux distro tested,
this printer always worker very well, installed via CUPS and the IBM Execjet 4072 Foomatic/bj200 driver.
The printer is connected via parallel:/dev/lp0. It is possible I don't know some peculiarity of Sparky, that is new for me.
Now the printer don't accept any work with the error "Filer Failed".
I have installed SparkyLinux 5.7 "Nibiru" - Multimedia flavour.
I thank you very much for all your help!!!
(P.S. : Printing is very important for me and if I don't solve this problem, I think I have to change distro  :-( :-( :-(   )

kanliot

Hope you can fix your issue.  I didn't read what the problem was.

I'm probably not qualified to help you, but I hope this helps https://wiki.debian.org/SystemPrinting#Software_Installation

Sy41CL

Hi, thank you for help.
I visited openprinting.org and downloaded all drivers suitable for my Lexmark 2491:
- IBM-Execjet_4072-bj200.ppd;
- IBM-ProPrinterII-ibmpro.ppd and
- Generic-IBM-Compatible_Dot_Matrix_Printer-ibmpro.ppd.
In the past I used all of this drivers, but I prefer the IBM-Execjet_4072-bj200
because is the only that works with the graphic capabilities of my printer.
With all of these drivers, I obtain from the system, NOT THE PRINTER,
the same error "Filter failed".
I hope for help resolving this problem...
Again, Thank you very much.

kanliot

Thanks for the response, but I am still not confident.

When it says "Fiter failed"  is this in openoffice? 
What is the name of the window?

Also,  is this stable  sparky or the new rolling  sparky linux install?

kanliot


Sy41CL

Hi, the error "Filter failed" occurs in CUPS when I try to print the test page.
I have installed SparkyLinux 5.7 "Nibiru" MULTIMEDIA in the rolling version.
Again Thank you very much for your effort to help me!!!

Sy41CL

#6
Hi, I posted the CUPS error log in pastebin at https://pastebin.com/Zjwj8dAv
Again, thank you for help! 

pavroo

Your file has been removed, see nothing.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Sy41CL

I am sorry, I typed wrong the address, but now is correct.

Sy41CL

Thank you so much for all your help!!!
The problem was the authorizations of /dev/lp0
set to 660. I changed it to 666 and the printers
works now very well with the usual driver
IBM Execjet 4072 Foomatic/bj200.
Again, thank you very much!!!

View the most recent posts on the forum