Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

WiFi Won't Work Dell Inspiron 3520

Started by elemmaiii, December 29, 2018, 09:21:01 PM

Previous topic - Next topic

elemmaiii

Hi. As the subject states I can't get the wifi to work on a Dell Inspiron 3520. In researching I've found I need to install drivers for a broadcom bcm4312. I've followed instructions to try and fix this issue with these instructions:

"The module doesn't work out of the box.
It needs packages to be installed (other internet connection needed):
Code: [Select]

sudo apt update
sudo apt-get install linux-headers-amd64 build-essential dkms broadcom-sta-modules

amd64 or 686-pae or 686 suffix
then:

sudo apt install wireless-bcm43142-dkms

then try:

sudo modprobe wl"

Everything works fine until I get to the modprobe wl command. I get the following error:

"modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name='wl'
modprobe: ERROR: could not insert 'wl': Unknown symbol in module, or unknown parameter (see dmesg)
modprobe: ERROR: ../libkmod/libkmod-module.c:979 command_do() Error running install command for wl
modprobe: ERROR: could not insert 'wl': Operation not permitted"

In the past, I was able to finagle a fix, but it only worked on a 4.18 kernel. I was messing around today trying to get it to work on the newer kernel that this computer has  (4.20) and I ruined the previous fix that worked on the 4.18 kernel. How do I fix this issue? I'm only a novice when it comes to linux, so your explanation would need to be pretty elementary. This computer is running Sparkylinux 5 Buster testing w/kernel 4.20.0-sparky-amd64. Thank you in advance.

elemmaiii

lspci -nn -d 14e4:
07:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01)
^-Is my specific Broadcom chip.

pavroo

Run your system using Debian's default kernel, then run:

sudo apt-get update
sudo apt-get install --reinstall linux-headers-amd64 build-essential dkms broadcom-sta-modules
sudo apt-get install --reinstall wireless-bcm43142-dkms
sudo modprobe wl
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

elemmaiii

Unfortunately, your suggested repair didn't work. I believe it's simply the kernel. I regressed the kernel to 4.19 and deleted the new kernel so when my son restarts his computer it doesn't default to the kernel that doesn't support his wifi chip. I am, however worried that an update will install the new kernel again and then I'll have to address this issue again.
I deleted the debian "unstable" updates from the repository. Will this suffice?

lami07

To stop Sparky kernel from autoupdating you need to do one of those things:
A) remove linux-image-sparky-amd64 metapackage or
B) comment out the content of /etc/apt/sources.list.d/sparky-unstable.list
Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//irc.freenode.net"]irc.freenode.net[/url]

elemmaiii

Thank you everyone for your replies. I love Sparkylinux and this was an issue for me when I had Linux Mint on this computer as well. I'll just have to remember that the newest kernel likely won't work for this computer and I'll have to keep it from the most bleeding edge kernel.
Is there a way for me to close this thread?
Thanks.

View the most recent posts on the forum