Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Kernels 4.19 & 4.20 missing features for Docker

Started by braindead, December 25, 2018, 07:47:06 PM

Previous topic - Next topic

braindead

Hi all,
thanks for the impressive work with Sparky...
I tried to install Docker CE but ir regused to start with existing Sparky kernels 4.19 & 4.20...
Installing the Debian buster 4.18 kernel and it starts fine.....
I think it might be helpful ...
Problem seems to be lacking features related to cgrouo but present in standard Debian kernel.....

Best regards & merry chrimtmas to the PSarky community...

paxmark1

Off to work. I  lurk (watch silently) on a sid-unstable forum. In Sid -  slightly more problems than normal with kernel 4.20 (towo's  but also most 4.20's in Debian) and with systemd 240.0  (Hopefully testing skips 240.0 and goes straight to 240.1)

Most common one is https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917173    several merged into it.

Lurking in debian-next irc will not hurt either.  NOTE:  they will probably not aid you much as their stated purpose in for pure debian systems.  debian-kernel irc might also have

But hopefully others here might have help.  Off to work, unfortunately not double time and a half like in Canada for Boxing day.  Still will be overtime.  Peace out.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

pavroo

There is linux-image-4.19.13-sparky-amd64 & headers in sparky unstable repos so refresh package list and install to give it a try.
It runs docker fine (and a few other things) now for me, so I need your confirmation, please.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum