Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Cant boot to GUI

Started by Irets, November 02, 2018, 02:44:00 PM

Previous topic - Next topic


I have SparkyLinux 5 x86_64 "rolling" installed with the latest sparky kernel, and after the latest upgrade, I cant boot into GUI at all.
I just boots into CLI but after a longer wait than usual, if I was booting to my desktop.
I had the lxqt-desktop installed with openbox as my window manager.
I'm stuck at CLI and dont know how to get back to my desktop.
Here are some screenshots I took with my phone, so the quality is a bit blurry.
There seems to be a problem with openbox and/or Xserver
I also have Nvidia's proprietary driver installed.
Typing "echo $DISPLAY" doesn't print out anything.
I can provide you more info about my system/problem by replying to you.
This is really urgent because I cant use the machine for basic tasks currently at all.

Examples of the problem:

Pictures from .xsession-errors


First try Ctl-Alt-F7 to see if you get X back,  probably not.  Ctl-Alt F1 will get you back to vt1 (virtual terminal 1)

I had a stuck apt full-upgrade on an xorg - binary.  Can't remember what it was.

If you do command line, "dpkg --configure -a" is pretty safe, if errors messages appear, please copy via Ctl-Shift-C from terminal and post errors (if possible).

There has been a change in "su" awhile back (sbin versus bin blah blah blah) 

If you are in command line - then as root try "su - root" instead of "su root"  That is what made my stuck upgrade progress.  "dpkg --configure -a" did not solve my problem this time.  relogging in as "su - root" worked for me.  If not wait for someone else to post methods that use Aptus or synaptic. 

There has been some writing about the su - root change, but it is hard to follow.  One recent post of unstable debian users helped me a little in understanding it better, but I am still not sure about the "why's"   

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


WHat happens if you start the desktop manager from the CLI?  At the prompt type

or perhaps

Do either of those invoke your GUI login manager?


Hi and thank you for your replies.

I tried the CTRL-ALT-F7 button combo but nothing happens.
I also tried doing "sudo dpkg --configure -a", but I don't think it did anything.
It finished the command as soon as I hit enter and nothing appeared on screen about the command actually being run, which is weird.
I've read that other people have had that same issue too, when they've gotten stuck at the CLI.
I still did a few test commands with dpkg to see if it was working with other commands, like reading the --version and --help.
It worked just fine.

I managed to get in as root by typing "su - root" and did the following commands:
sudo apt-get update
sudo apt-get upgrade
sudo dpkg --configure -a
sudo lightdm
sudo sddm

It behaved exactly like it would have if I would have instead done "su root", and repeated those same commands.

Also now that I start thinking, I think that the last update freed like ~200mb of disk space, is that normal?
One possibility is that it might have deleted something but failed to bring back the updated version of it?
Like some random individual files that could cause a problem of this sorts?
Atleast the core system is stable and working, so I dont think any important system files are missing.

Typing in sddm or lightdm just says "unknown command".


Note:  You should not need to use "sudo" when logged in as root.  "sudo" is used when you are in a normal terminal and you want root permissions when logged in as a normal user.   

When "dpkg --configure -a"  gives no response, that means it could not find any partially configured packages.  That is a good response. 

"Other people had that same issue too."         Where - what irc or forum?  When, was it in the last few days?  What OS if different than Debian (Sparky)  What DE if different than lxqt?   

Do you have any holds on packages?  Either via pinning or apt-mark hold?  (If you do not know you probably do not.)

My short glitch with xorg was in i386 Atom sparky been rolling for a couple of years in lxqt. 

I just did apt full-upgrade in my Virtual amd64 sparky lxqt to try to replicate.  No luck replicating. 

Is your xorg-server version 2:1.20.3-1  or   2:1.20.2-1   ?           

Is your xorg 1:7.7+19      ?

edit   To investigate whether it is sddm or lightdm  and if active I would use something like

systemctl status lightdm

systemctl status sddm.     One or the other should come up during the boot process.  My guess is that it is lightdm.  A little green square and a green "active (running) will indicate if it is working.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


I was browsing links from google search results when I was googling about my problem, before I posted on this forum.
They told the original poster to do "dpkg --configure -a", and for some it gave no response. (cant remember which site this was on and what configuration he had)
Then the original poster replied to someone and asked for a "fix" for why there was no response, so I thought it was a problem and I didn't do any more research on the reasons why he didn't get any reply.
Thanks for clearing that out, I thought there was a some kind of an "issue" with dpkg too.
Didn't know it was a good thing that it doesn't give any reply.

About the xorg-server and xorg, how can I check their versions?
I typed "xorg" and hit tab to see available commands and there were none.
I also tried some variations of it, like "Xorg", "X-org" and such.

I dont think that I have any packets on "hold", because I don't know what it even means or does.
I'm not super experienced user and this CLI stuff is still a bit new to me, as i'm used to doing most things through a GUI.

Here are the results from
systemctl status lightdm
systemctl status sddm

The little square is red.


After browsing Arch forums, I got the idea to try starting lightdm manually by using "sudo systemctl start lightdm", but with no success.

Contents of "sudo journalctl -xe":

There doesn't seem to be much useful information.


Do you have active internet connetction at cli?
Test via:
sudo ping -c 1
If yes, try to install different login manager, I suggest slim:
sudo apt update
sudo apt install slim

Then choose slim as default and restart:
sudo reboot
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I browsed the internet through lynx so I should have connection.
When I install slim, do I get to keep my lxqt desktop and my programs?
When slim is installed, how can I choose it as default?


If you have internet connection, simply install slim as I posted befor.
During installation proces, you will be asked what session manager you want to use as default, so choose slim, then reboot.
If everything ok, the system will display slim instead of lightdm, which lets you log in to your desktop.
Just try.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I got slim installed and set it as default login manager but unfortunately I still get booted to CLI.
The only difference is that now it says "A start job is running for Network manager Wait Online (seconds / no limit) when booting.
After that the CLI shows up.

Here's the output of "systemctl status slim"

It shows the same small red square on the top left of the screen, just like with lightdm when I ran that same command previously in this thread.

If I try to run slim manually by typing "sudo slim" It prints the following error:
/usr/bin/X11/xauth:   file /var/run/slim.auth does not exist


I did "systemctl status slim" again and this time it has more text.

Also I checked if the file really was missing, but its not.


The first screenshot says that it can not find /usr/bin/X so try to reinstall it:
sudo apt update
sudo apt install --reinstall xorg xserver-xorg xserver-xorg-core

or install it back if not installed:
sudo apt update
sudo apt install xorg xserver-xorg xserver-xorg-core

then reboot.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


After doing
sudo apt update
sudo apt install --reinstall xorg

I rebooted but the CLI still shows up.
Here's what the CLI login looks like after it has finished booting.

You can see the login field at the top left between the letters.
I used neofetch to clear the screen the screen of text after logging in.
Using "clear" brings back the text and then I have to clear it again with some terminal program which outputs empty lines, like neofetch or just by typing "ls" a couple of times.

Using "sudo lightdm" brings me to an empty CLI but with a higher pixel density and with no input or output.
I can go back and return to it using CTRL+ALT+F7 - F1 buttons.
Here's what came up on the regular CLI when I returned to it.

Here's what shows up when I type "sudo slim"
I had to take multiple pictures so I'll post them in the same order as the text goes.


Contents of Xorg.0.log




I have edited my last post, there are 3 packages to be reinstalled.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]

View the most recent posts on the forum