Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[solved]Boot Problem after install

Started by john261, October 14, 2018, 04:43:01 AM

Previous topic - Next topic


Sorry if this has been addressed before but I am new to all this.  I just installed the SparkyLinux on my AlienWare 15r4 laptop.  I have a 2TB ssd and a 1TB 7200rpm hard drives.  I installed Sparky on the 2TB drive.  Install seemed to go fine.  I installed from a flash drive because I do not have a CD drive.  After install I removed the flash drive pressed F12 to boot from the SSD and nothing happens.  I just get a black screen.  No boot loader or anything.  I have the boot setup as UEFI.  Any suggestions?


Are you dual booting with windows? 
What operating systems do you have on your computer and on what drives are they located.
Did you have a previous grub2?
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


I am not dual booting. 
I did a fresh install of only Sparkylinux.  I did try Ubuntu Game Pack but when I did the install of Sparkylinux I installed over ubuntu Game Pack. 
Nothing else is on the drive.


In a UEFI setup, grub installs to EFI partition by default.  By pressing F12 and booting from SSD it sounds like you're skipping over the efi/grub boot and it's hanging.

What happens if you allow normal boot sequence from default drive?  You should get expect to see a UEFI/grub bootloader that either loads the first/default entry in grub, or allows you to choose in dual-boot or multi-boot situation.  If that isn't what happens by default, your grub is installed in the wrong location.

Could be a pretty simple fix, but can't really help until paxmarks questions are answered.


I just tried letting it try to load naturally and all it does is go to a black screen and there is a white line on the left of the screen.  It just hangs on that screen.  I am not dual booting.


Ok so I went in to Bios and I did not realize it but my boot option had been changed to Legacy.  I switched to UEFI and it shows Sparky.  I saved the changes and now boot up and it goes to a black screen that shows:
>>Checking Media Presence........
>>Media Present.......
>>Start PXE over IPV4.

Then I let my computer sit on that screen but after a few minutes it boots in to a Alienware program that tests my computer and it finds no errors.
Thank you for the help


That's interesting.  Your computer is tryiing to boot over network connection, which is usually a "last resort" method.  That tells me your grub is completely skipped over (or missing completely), and ends up defaulting to PXE.  Beyond that, I don't really know much, as I haven't seen this error before.

Is this page helpful:

If not, can you still boot from the live installation media?  If so, install boot-repair (using Debian DEB package in link) and perform "recommended repair".  Tutorial here:

I haven't had many problems with grub over the years, but the few times I have, this has worked for me every time.  FWIW...


I actually got my problem solved.  I used DiskGenius and did a full wipe of my hard drive and then reinstalled Sparky and now it works.  I appreciate everyone adding input in to this.  Thank you very much.

View the most recent posts on the forum