Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[Solved] - Safe remove all obsolete versions of GCC

Started by AxL, July 30, 2018, 11:20:02 PM

Previous topic - Next topic

AxL

@pavroo

First of all, I would like to congratulate and thank pavroo for his excellent work with SparkyLinux.  ;)


My SparkyLinux 'Buster' installation, is more than two years old (since May 2016').
During this period of time, I have installed all available updates every day.
And in this time I have accumulated a lot of obsolete versions of gcc (4.6/4.7/4.8/4.9/5/6/).






So, my question is very simple: can I remove all obsolete versions of GCC without causing any problems? ???

How should I remove all those versions except GCC 7/8?







Cheers!!   8)

pavroo

#1
I pretty think you should.
Removing one after one, you will get a message from the APT - if no important system packages will be removed, you can uninstall them.
Buster works on gcc 7.x and 8.x now. The default is 8.x now, but the latest Debian's kernel still needs 7.x.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

AxL

Quote from: pavroo on July 31, 2018, 01:00:34 AM
I pretty think you should.
Removing one after one, you will get a message from the APT - if no important system packages will be removed, you can uninstall them.
Buster works on gcc 7.x and 8.x now. The default is 8.x now, but the latest Debian's kernel still needs 7.x.

    Thank you very much for your quick response. ;)

    I have removed all the obsolete versions of GCC, as you told me (one by one),
    without any issues.






    Cheers!!    8)

View the most recent posts on the forum