Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Trackpad / Synaptic issues in minimal GUI

Started by niftyprose, May 19, 2018, 01:49:38 PM

Previous topic - Next topic


Hi guys, I posted about this one in the newbies forum with no responses, so thought I should post a more detailed version here.

I just installed Sparky 4.8 / minimal GUI (=OpenBox) on an Asus E200H. The system is working well but the trackpad response is erratic. When I click-and-drag a window, I experience very rapid jumping around the clickpoint. It's confusing, and is likely to result in moving the window to the wrong place. A USB mouse works perfectly.

My guess is that this is YA instance of the Synaptics/libinput issue that's been dragging on for years, but the fixes I used in Bunsenlabs and Crunchbang don't work here. I already tried moving I'm fairly sure I could identify the problem for myself given sufficient time but I imagine that other forum members may have  experienced this. If so,  any pointers would be appreciated.


Well, You added more info this time.   I was going to post that you needed more info.

Have you read any posts by me here on synaptic versus libinput.

please review the Debian change logs of libinput versus xserver-xorg-input-synaptics   - search of Debian package "blah" works well. The diff between  updates of  libinput and x.x.i.synaptics is huge.   First change log is free. 

At work I am provided  very stale  linux mint for data input on refurbed laptops in a licensed residential setting and the non-systemd LM17 version results in data loss - all too often via x.x.i-synaptics.  If you are not on systemd, I would strongly recommend it for the long haul and I would strongly recommend using libinput. 

1. Asus eee900A with lvm in deb testing and mate and 2. acer aspire on with Sparky 5 lxqt been awhile since I had libinput issues. 3. I did have some easily fixed problems in Stretch when it was testing  with libinput on my main box,  and 4. in sid on EEEbox and AMD-c50 with libinput, easily fixed.    I do not have the data loss problems when I work at home with Acer or i3 intel box where I get to control my OS. 

peace out.

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Hi Paxmark, thanks for the reply and sorry for the initial sketchy post. I guessed (wrongly) that many other people would have experienced the same problem and wanted not to bore them. Since it's just you and me for the moment I'll provide even more detail on the problem. (I did my own reading on libinput after posting, although I'll follow up your pointers too, natch.)

I'm actually experiencing two distinct trackpad/touchpad problems:

#1 is that the entire surface of the trackpad is responsive to drag input. This means that, if I click-and-drag, the software sees positional input both from the dragging finger and the one holding down the button, and jumps between them. I should be able to fix this one myself once I've figured how to access the pointer coordinate system in libinput, and I'll post the details here when I've done.

#2 is that YouTube messes up the interface. If I visit the site, the pointer input goes mad and stays that way until I reboot. I suspect that this may have to do with (gah!) Flash but I really don't know what's amiss. Any ahem pointers would be gratefully recd.

Best, W.


Does the erratic behavior continue when you use the laptop without a charger?


Aha! Actually, no. Thank you Seppalta. Do you have some insight into the situation? Best W.


The charger you are using has too much power for your laptop especially when the battery is full or nearly full.  Get a cheaper lower powered charger.  Some times bigger and better isn't!


Hiya Seppalta, thank you for the input. The slow reply is because I wanted to recover my Asus transformer and confirm. You're right: the cursor *doesn't* jump with the Asus transformer, only the generic one. I'd never have expected the problem to be anything so simple.

However,  all this begs a further question. I used a simillar Asus netbook on BunsenLabs with three different transformers -- no problems. Can anyone indicate why the problem comes up in Sparky.

Best, NP


I do not know the answer to your question but I doubt if it has anything to do with the operating system.  It just seems to happen randomly, and in so much as I remember, happened to me with other operating systems.


Hiya Seppalta (and other visitors),

I think that the erratic cursor relates to Sparky, but this is anecdotal and I can't say f'sure.

Background: I previously used an Asus X205 with #! and BunsenLabs. Because I move around a lot, it was convenient to have three different power supplies, only one of which was Asus-branded. The computer worked fine in the UK and EU for years.

I'm now on another Asus netbook which I bought on eBay as an X205. When it arrived, it turned out to be an E200H, which has the same case and display as the X205 and almost identical hardware but a slightly different processor. I notIced the cursor issue as soon as I substituted Sparky for Windows. I suppose it *might* be related to the different processor but it seems unlikely.

If anyone has a fix I'd be delighted to hear it. Otherwise, I'll leave the topic here in case anyone else is experieniing the same problem as me.

Best, W.


Some of my libinput glitches was in #! in testing, they all got fixed. I tend to believe that it is not Sparky at fault, you would probably have the same results in Debian. 
1.  Are you using libinput-bin or the 2012 code from xorg.blah.synaptic?
2.  Use lspci to determine what exactly is your brand/type of touchpad. Research and post output
3.  It is not used so much here but elsewhere "inxi" is used to post hardware setting to forums. 
4.  I do not go there as often, but you might get an answer in Bunsen, I have in the past even when I identified myself as on Debian testing. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Hi guys, sorry for being absent from country is a mess nowdays...anyway

If you came from minnimal GUI, you need to build up the entire system, so many packages and drivers are not installed by defaul, like synaptics (the universal touchpad driver).

Give a test:
sudo apt install xserver-xorg-input-synaptics

Tell me if it works. It should enable a better setting at the config GUI of the system you're using...
"Great spirits have always encountered violent opposition from mediocre minds."
Albert Einstein

View the most recent posts on the forum