Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[SOLVED] The icon of NetworkManager Applet disappeared

Started by foreigner, March 08, 2018, 08:22:41 PM

Previous topic - Next topic

foreigner

Hello

I installed, a few days ago, SparkyLinux 5.2 MinimalGUI (Openbox only) 64 bit on my laptop.
Today the icon of NetworkManager Applet (usually placed on the tray bar, near the volume icon) disappeared.
The Ethernet (wired) connection works, but I can't disconnect the wired connection and select a wifi network.
How could I restore the icon?
Alternatively, I could handle connections using the terminal, but I would need some suggestions.

Another (less important) issue, about Synaptic, Gufw and GParted (installed by me): in the past days the menu (the one you can open with a right click on the desktop) worked well to launch these programs. Now, the respective entries don't work anymore and I have to launch these programs using the terminal. The menu works fine with the other entries.

Thanks for your help  :)

pavroo

Yes, I saw that too.
Looks like the Openbox doesn't read the system's autostart options, so have to put some of them to openbox autostart manualy.
Edit ~/.config/openbox/autostart.sh file and add the lines to it:
sparky-polkit &
make sure you have 'sparky-polkit' package installed
/opt/sparky/nm-applet-reload &
make sure you have 'sparky-nm-applet' package installed.
Then relogin/reboot to take effects.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

foreigner

Pavroo, thank you for your answer and your help.
The changes you've recommended to ~/.config/openbox/autostart.sh worked perfectly.

Thanks.

View the most recent posts on the forum