Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Tablet install?

Started by lesinlondon, March 01, 2018, 04:55:21 PM

Previous topic - Next topic


Hi people. I'm having a problem installing Sparky on my hybrid tablet and would appreciate any guidance. Details are -

10" IruLu hybrid. 32bit efi bios, 64bit quad core BayTrail cpu, running 32bit Windows 10 Home (very nicely).

I get as far as booting the usb drive and selecting Sparky, then, after some scrolling text the screen goes blank and just hangs there.

I have tried on an old laptop and all went fine, installed without problem. The images I have tried to install are - 32bit (i686 non-pae). Safe boot disabled.


I'd love to get Sparky installed on the hybrid, even if that means having the keyboard permenently attached and no touch screen. Can anyone advise?



Hi man!

I guess you're trying to install a non compatible iso with your CPU. It is 64bits, so you need to try or pure 64bits or better multiarch (home edition is).

This is your processor real name:

Also, take a time to read this, it can help on search for information on install (because Sparky is based on Debian):,4243.msg10591.html
"Great spirits have always encountered violent opposition from mediocre minds."
Albert Einstein


Hi Capitain_Jack. Thanks for the reply. Since my post I have tried a 64bit version, but still no luck. Select Sparky and after some scrolling text it just hangs.

I am almost completely Windows free, just this fairly new tablet hybrid to convert, if possible. I watched a youtube video about installing Linux on cheap tablets pre-installed with 32bit Windows and there was a comment that some of them have the bios locked to install Microsoft only OS'. I don't know if that's correct. Can't find anything in the bios.

Anyway, thanks for the link to the processor page, I have saved it as it might come in useful; and the other post link, which I will read.

Update: I had a dig about in the bios again and buried deep in a sub-sub menu was OS/BOM Congiguration. Settings were -

BOM Selection Switch: Force Windows 8x / BOM 3.1
Pre-Os BOM Selection: Windows 8x / BOM 3.1

Both are fixed settings and cannot be changed. I think I have my answer - no can install Linux :(

View the most recent posts on the forum