Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[SOLVED] left click mousepad tap not working

Started by poohduck, January 02, 2018, 07:11:58 AM

Previous topic - Next topic


hello all. I'm a newbie, and have returned after a break to linux. After troubleshooting left tap not working on my synaptics mousepad, the only fix that worked (none of the xorg stuff) was:

synclient TapButton1=1

My next problem was where and how to run this as a script at logon or startup. Because I'm running openbox (minimal resources), I thiink this is why there is neither of the following, that would seem to be the normal place to put a script:


While looking for the above, I did find (in a round about way)

$HOME/.config/openbox/autostart. I put the "synclient TapButton1=1" just under the first line which is - #! /bin/bash

I can imagine there might be no one else with the combination of openbox and no left tap, still  :)


OK, I've returned to this netbook to set it up for a friend and noticed it still had a flaky mouse. This is regards left click. I've found the better fix that is solid.

I had to disable the libinput driver and enable the synaptics driver:

...basically went to etc/X11/xorg.conf.d
...renamed 40-libinput.conf to 40-libinput.old
...created synaptics.conf, and typed the following
...Section "InputClass"
        Identifier         "Touchpad"                         # required
        MatchIsTouchpad    "yes"                              # required
        Driver                "synaptics"                        # required
        Option                          "TapButton1"               "1"   

Reboot and all is good.

View the most recent posts on the forum