Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Upgrade Problem

Started by dhinds, January 05, 2018, 10:16:57 PM

Previous topic - Next topic

pavroo

Aaaaaaaa.........
You have two autostart files...
Openbox reads the autostart (with no "sh" extension) as first.
The first line is xfce4-panel, thats why it loads it itself, but the file is not set properly so next lines commands don't start.
So...
Go to /home/dhinds/.config/openbox directory
Delete /home/dhinds/.config/openbox/autostart file.
Edit /home/dhinds/.config/openbox/autostart.sh file and set is as follow:
#! /bin/bash

nitrogen --restore && \
xfce4-panel &
xscreensaver --nosplash &
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &


then reboot and let me know what happend.
don't start sparky-polkit manually, have to know is gnome-polkit started itself, so check:
pidof polkit-gnome-authentication-agent-1

QuoteWhat can you tell me about debian support for btrfs, zfs or nilfs2?
sorry, you have to check it at Debian's wiki or so.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

dhinds

 Doing that now.

Rebooting.

dhinds

Now everything loads except tint2

Good Job, pavroo.

(So Sparky is not designed for use with btrfs or zfs)?

pavroo

If you need tint2 to be loaded, simply add it to the /home/dhinds/.config/openbox/autostart.sh
tint2 &
on the end ot the file.

Btrfs status check here:
https://wiki.debian.org/Btrfs

zfs:
https://github.com/zfsonlinux/zfs/wiki/Debian
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

dhinds

Quote from: pavroo on January 14, 2018, 05:37:08 PM
If you need tint2 to be loaded, simply add it to the /home/dhinds/.config/openbox/autostart.sh
tint2 &
on the end ot the file.

Btrfs status check here:
https://wiki.debian.org/Btrfs

zfs:
https://github.com/zfsonlinux/zfs/wiki/Debian

Perfect.

Thanks a lot, pavroo.

Once again you have demonstrated conclusively why Sparky is the best debian derivative available.

View the most recent posts on the forum