Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[SOLVED] Error installing gimp,audacity and other packages problem

Started by penguin, January 29, 2018, 07:33:33 PM

Previous topic - Next topic

penguin

Today my Sparky 4 xfce conluded an update.I had some times that I did not done it.Ok.Up to here fine. But when began to install some programs, an error in Synaptic for broken packages did not allowed me.
I tried to repair this problem from Aptus. No way.I tried to repair by
Quotesudo apt-get install -f
also
Quotesudo dpkg --configure -a
also
Quotesudo apt-get update && sudo apt-get upgrade
, but still error persisted on Synaptic.
Strange but some of this softwares I arrived to install in Terminal way sudo apt-get (software).
Some others was impossible to install and for this reason I downloaded deb from net ( deadbeef, pinta etc).
Now I trying to install Gimp from Synaptic and I get error :

Quotegimp:
Depends: libgimp2.0 but it is not going to be installed
Depends: libgimp2.0 but it is not going to be installed
Depends: gimp-data but it is not going to be installed
Depends: gimp-data but it is not going to be installed
Depends: libbabl-0.1-0 but it is not going to be installed
Depends: libgegl-0.2-0 but it is not going to be installed
Depends: libjasper1  but it is not installable

in terminal for gimp
Quotesudo apt-get install gimp
Quotegimp : Depends: libgegl-0.2-0 (>= 0.2.0) but it is not going to be installed
        Depends: libjasper1 but it is not installable
E: Unable to correct problems, you have held broken packages.


for audacity Synaptic gives this error :

QuoteDepends: audacity-data (=1:2.1.3+git7911-2ee3ba576-1) but 2.1.2-1~14.04 is to be installed
Depends: libavcodec56 (>=10:2.6.9) but it is not installable
Depends: libavformat56 (>=10:2.6.9) but it is not installable
Depends: libavutil54 (>=10:2.6.9) but it is not installable
Depends: libportsmf0 but it is not going to be installed
Depends: libsoundtouch0 (>=1.8.0) but it is not installable
Depends: libsuil-0-0 but it is not going to be installed
Depends: libvamp-hostsdk3  but it is not installable
Depends: libwxbase3.0-0 (>=3.0.2) but it is not installable
Depends: libwxgtk3.0-0 (>=3.0.2) but it is not installable

in the terminal
Quotesudo apt-get install audacity

QuoteThe following packages have unmet dependencies:
audacity : Depends: libavcodec56 (>= 10:2.6.9) but it is not installable
            Depends: libavformat56 (>= 10:2.6.9) but it is not installable
            Depends: libavutil54 (>= 10:2.6.9) but it is not installable
            Depends: libsoundtouch0 (>= 1.8.0) but it is not installable
            Depends: libvamp-hostsdk3 but it is not installable
            Depends: libwxbase3.0-0 (>= 3.0.2) but it is not installable
            Depends: libwxgtk3.0-0 (>= 3.0.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

hmmmmm. Just a I`m trying to make the same thing in another machine on which I have the same Sparky installed... No problem at all here.Sparky that creates me problem is not used so frequently and  also had a long month without updates in December. Does not cost me nothing to copy by dd command Sparky from this machine to other one, but I want to understand what happen.


pavroo

Looks like you have external repositories added, do you (14.04 says it's about *buntu)?
Quoteaudacity-data (=1:2.1.3+git7911-2ee3ba576-1) but 2.1.2-1~14.04 is to be installed
Show me:
cat /etc/apt/sources.list
grep . /etc/apt/sources.list.d/*
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

penguin

Hmmm.
Because I failed to install Audacity by Synaptic,I thought to use deb  files downloaded from Internet (audacity and audacity-data).Because all deb files for Debian failed to install with gdebi(for incompatibility of dependencies),I used deb files from Ubuntu Repository.Audacity-data needs to be installed first and I installed it. The rest of the errors comes from this. I have not any Ubuntu Repos. Because I did not arrived to install also from these Ubuntu debs,I removed audacity-data.The strange things that I have seen with this Sparky (I do not use it not ),was that on January for a time, he did not get updates (I did not used it since november). I tried to update but no updates. Today updates was roundly 408 MB (also kernel). The errors on Synaptic occurs after.I did not noticed this problem before.   
Do not consider Audacity on this case. For this moment I can not install Gimp (before happens with pinta,deadbeef, etc).May happen also with other packages but I have no tried. As I said on the previous post,I managed to install (pinta,deadbeef and some other programs from deb files downloaded from Internet).

cat /etc/apt/sources.list
deb http://ftp.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free
deb http://www.deb-multimedia.org/ stretch main non-free

##
##
##
## Other repos can be found in /etc/apt/sources.list.d directory ##

deb https://notesalexp.org/debian/jessie/ jessie main


grep . /etc/apt/sources.list.d/*
/etc/apt/sources.list.d/google.list:## google-chrome web browser
/etc/apt/sources.list.d/google.list:# deb http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/google.list:## google earth
/etc/apt/sources.list.d/google.list:# deb http://dl.google.com/linux/earth/deb/ stable main
/etc/apt/sources.list.d/google.list:## google talk plugin
/etc/apt/sources.list.d/google.list:# deb http://dl.google.com/linux/talkplugin/deb/ stable main
/etc/apt/sources.list.d/google.list:## google music manager
/etc/apt/sources.list.d/google.list:# deb http://dl.google.com/linux/musicmanager/deb/ stable main
/etc/apt/sources.list.d/liquorix.list:# Liquorix kernel
/etc/apt/sources.list.d/liquorix.list:# deb http://liquorix.net/debian/ sid main 
/etc/apt/sources.list.d/liquorix.list:# deb-src http://liquorix.net/debian/ sid main 
/etc/apt/sources.list.d/megasync.list:deb https://mega.nz/linux/MEGAsync/Debian_9.0/ ./
/etc/apt/sources.list.d/opera-stable.list:# This file makes sure that Opera Browser is kept up-to-date
/etc/apt/sources.list.d/opera-stable.list:# as part of regular system upgrades
/etc/apt/sources.list.d/opera-stable.list:#OperaBrowser (final releases)
/etc/apt/sources.list.d/opera-stable.list:deb https://deb.opera.com/opera-stable/ stable non-free
/etc/apt/sources.list.d/palemoon.list:deb http://download.opensuse.org/repositories/home:/stevenpusser/Debian_9.0/ /
/etc/apt/sources.list.d/pipelight.list:# deb http://repos.fds-team.de/stable/debian/ sid main
/etc/apt/sources.list.d/playonlinux.list:# deb http://deb.playonlinux.com/ wheezy main
/etc/apt/sources.list.d/sid.list:## sid
/etc/apt/sources.list.d/sid.list:# deb http://ftp.debian.org/debian/ sid main contrib non-free
/etc/apt/sources.list.d/sid.list:# deb-src http://ftp.debian.org/debian/ sid main contrib non-free
/etc/apt/sources.list.d/sid.list:# deb http://www.deb-multimedia.org/ sid main non-free
/etc/apt/sources.list.d/skype-stable.list:deb [arch=amd64] https://repo.skype.com/deb stable main
/etc/apt/sources.list.d/sparky-stable.list:### sparky stable repository
/etc/apt/sources.list.d/sparky-stable.list:### used on sparky based on debian stable only
/etc/apt/sources.list.d/sparky-stable.list:deb https://sparkylinux.org/repo/ stable main
/etc/apt/sources.list.d/sparky-stable.list:deb-src https://sparkylinux.org/repo/ stable main
/etc/apt/sources.list.d/sparky-testing.list:### sparky testing repository
/etc/apt/sources.list.d/sparky-testing.list:### used as default by all sparky editions
/etc/apt/sources.list.d/sparky-testing.list:deb https://sparkylinux.org/repo/ testing main
/etc/apt/sources.list.d/sparky-testing.list:deb-src https://sparkylinux.org/repo/ testing main
/etc/apt/sources.list.d/sparky-unstable.list:### sparky unstable repository
/etc/apt/sources.list.d/sparky-unstable.list:# deb https://sparkylinux.org/repo/ unstable main
/etc/apt/sources.list.d/sparky-unstable.list:# deb-src https://sparkylinux.org/repo/ unstable main
/etc/apt/sources.list.d/virtualbox.list:# deb http://download.virtualbox.org/virtualbox/debian/ wheezy contrib
/etc/apt/sources.list.d/wine-staging.list:# deb https://repos.wine-staging.com/debian/ sid main


aptitude reports as follow:
Quotesudo aptitude install gimp
The following NEW packages will be installed:
  gimp{b} gimp-data{a} libbabl-0.1-0{a} libgegl-0.2-0{ab} libgimp2.0{a}
The following packages will be REMOVED:
  default-mysql-client{u} libdbd-mysql-perl{u} libdbi-perl{u} libjemalloc1{u} libterm-readkey-perl{u} mariadb-client-10.1{u} mariadb-client-core-10.1{u} mariadb-common{u}
0 packages upgraded, 5 newly installed, 8 to remove and 5 not upgraded.
Need to get 12.9 MB of archives. After unpacking 6,061 kB will be freed.
The following packages have unmet dependencies:
libgegl-0.2-0 : Depends: libavcodec56 (>= 10:2.6.2) which is a virtual package and is not provided by any available package

                 Depends: libavformat56 (>= 10:2.6.2) which is a virtual package and is not provided by any available package

                 Depends: libilmbase6 (>= 1.0.1) which is a virtual package and is not provided by any available package

                 Depends: libjasper1 which is a virtual package and is not provided by any available package

                 Depends: libopenexr6 (>= 1.6.1) which is a virtual package and is not provided by any available package

                 Depends: libopenraw1 (>= 0.0.9) which is a virtual package and is not provided by any available package

                 Depends: libumfpack5.6.2 which is a virtual package and is not provided by any available package

gimp : Depends: libjasper1 which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     gimp [Not Installed]                               
2)     libgegl-0.2-0 [Not Installed]                     



Accept this solution? [Y/n/q/?]

pavroo

1. Deactivate (with #):
# deb https://notesalexp.org/debian/jessie/ jessie main
in the:
/etc/apt/sources.list
You can reactivate it later, but I suggest to change "jessie" to "stretch".

Deactivate everything what you don't need now, in the files:
2.
/etc/apt/sources.list.d/megasync.list
repos:
#deb https://mega.nz/linux/MEGAsync/Debian_9.0/ ./
3.
/etc/apt/sources.list.d/opera-stable.list
repos:
#deb https://deb.opera.com/opera-stable/ stable non-free
4.
/etc/apt/sources.list.d/palemoon.list
repos:
#deb http://download.opensuse.org/repositories/home:/stevenpusser/Debian_9.0/ /
5.
/etc/apt/sources.list.d/skype-stable.list
repos:
#deb [arch=amd64] https://repo.skype.com/deb stable main

Refresh package list and try to upgrade all package, then try to install what you need.
If still problem exist, show me the output of of the broken apt's commands.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

penguin

Problem found. I think that problem was caused by follow repo that I am not sure how I added it on repos. In the other computer that Sparky Works fine , this repo does not exists.
deb https://notesalexp.org/debian/jessie/ jessie main
Also I deactivated :
http://download.opensuse.org/repositories/home:/stevenpusser/Debian_9.0/

the follow repo exists also in other laptop.
https://mega.nz/linux/MEGAsync/Debian_9.0/

Thank you pavroo !

View the most recent posts on the forum