Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

after an complete update, I can't reach my desctop screen

Started by Goofy, November 14, 2017, 10:15:19 AM

Previous topic - Next topic


Hello all, hello Pavroo,

Yesterday I did a complete update with the aptus tool: It was a very big download over 1,5 GB.
After rebooting the computer I could not get in anymore into the Sparky-Desktop!
I get just a command line screen with overline:
Sparky Linux mypcname tty1
mypcname login:

I can log in and can also type commands, but of course I want to get my usual desktop envirement!

After reading some topics here, I have tried the following commands, but without any effects:

sudo dpkg --configure -a
I cannot be sure if the system has done anything, because I've got no outputs after doing

sudo apt-get update
and also
sudo apt full-upgrade
these command were working

sudo apt-get install-f
it would working, if there were something new updates

sudo apt-get dist-upgrade
has also worked

But all didn't solve my problem that I can't get into my desktop!

Because I'm using the Grub-Bootloader, I have tried to start older versions of Sparky, but I get always the same:
The command line screen

The situation before that last update was, after choosen in Grub the Sparky line, I got a screen with a graphical textbox for login, where I could type my password: After doing this I've got my Sparky Desktop envirement.

Has anybody any Idea, what I could do now?


Goofy, what DE do you use? With such a BIG upgrade, how long since the upgrade before that?

Your mess is probably a bit too big a bite for me, but if you provide as much information as you possibly can, maybe somebody wiser than me can help you. :)
Unstable OpenBoxer


Thank you Blaze,

forgive me, but I don't know at the moment, what means the shorting "DE"?

Yes, I was also surprised because of that giant download: I do an update each one or two weeks, so last one can not be so long...


Hi Goofy, DE = desktop enviroment, Xfce, Mate or Gnome etc... :)

That such a giant upgrade should accumulate in two weeks sounds weird indeed. Have you done any major changes to your system during that period of time? What does your source list look like?
Unstable OpenBoxer


 :D of course DE = desktop envirement... Thank you again, Blaze   :)
Erm...yes... I was using the Sparky default one. I thought it was LXDE, could it be?

No, no major changes: My last actions were to install calibre, but this one doesn't make automaticly updates, and a pdf-software it true, I don't remember to the name  :-\
But a very small software.

I try to remember, which lines I watched during the update process... ...I had read that there was something strange with swap file; Some processes couldn't found it... But the process went on without any warning, so I was not worried... :-\

But of course I don't know if there is somehow a connection, with my problem now. My knowledge about all is to less to analyze this.


When you have logged in at tty1, have you tried with;


Edit; When thinking about it, the size of the upgrade were probably normal after that amount of time. I do not know what I were thinking of? Probably not thinking  ::)
Unstable OpenBoxer


After type in

I get the answer
/etc/X11/xinit/xserverrc: 3:exec /usr/bin/X: not found
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


Looks like X is missing, or something. ;) First;

sudo apt update && sudo apt dist-upgrade

Then try with;

sudo apt install xorg xserver-xorg xserver-xorg-core

A lot of xs, the worst that happens is nothing.

Unstable OpenBoxer


Hello guys,

tbh: i came to this thead following a link in another thread. And it does look horrible to my unexperienced eye. ;-)
Although, there certainly are ways to work around (a.k.a. log in, use commandline,...) that makes most sense, once you are certain, what actually did go wrong in the first place!

...brings me back to diagnosis...

As it seems pretty much like a nuisance, to fool around with a crucial system, let's have a look at the fastest ways to regain control over a messed up system, like

  • use a recovery CD
  • revert to a recent backup

Or is this already in such a bad state, that one has to recommend saving, what is needed after a complete reinstall to get your config + work files in place, and initiate a clean reinstall (possibly onto a different partition)?


I don't even know what version/desktop of sparky you have.
The first think you should do is trying to fix broken packages if any:
a. in recovery mode (easier)
b. using sparky rescue iso, and chrooter to chroot to broken system and fix it:
as root:
dpkg --configure -a
apt update
apt install -f
apt full-upgrade

Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]

View the most recent posts on the forum