Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

No boot screen?

Started by Lia, September 17, 2017, 01:52:52 PM

Previous topic - Next topic

Lia

When I tested the sparkylinux live it had an awesome boot screen with little animation in the bottom kind of like making a sideways 8 but after I have installed it, I only see the commands which boot the system, is there a way to get the boot screen back?

pavroo

It is installed by default, but if any problem, reinstall it:
sudo apt update
sudo apt install --reinstall sparky-plymouth

Then reboot to check it out.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Lia

Okay, re-installed and re-booted but that didn't do it. Still showing a bunch of commands, same thing at shutting down too, no screen just lots of commands with ok at the end. :-\

pavroo

Depends of your graphic card, settings can be different, so check:
https://wiki.debian.org/plymouth
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Lia

#4
I made some changes as suggested in that tutorial, I selected the sparky-blue amongst the others and it shows up now, I don't know if it is the same one which live one had but it looks like it and anything better than command showing up I guess.  :)

Thanks

BTW: What's this message all about?

I: The initramfs will attempt to resume from /dev/sda5
I: (UUID=b46c4a7d-f407-4ac2-8764-527509082617)
I: Set the RESUME variable to override this.


One more thing.. Is it possible to have system sounds, like maybe logon/logoff/notifications/errors etc.?

pavroo

The sparky's default plymouth theme is sparky-blue.

Edit, as root:
/etc/initramfs-tools/conf.d/resume
add the line to the file:
RESUME=UUID=b46c4a7d-f407-4ac2-8764-527509082617
(if it is correct UUID of SWAP partition, check via command:
sudo blkid | grep swap
If yes, then:
sudo update-initramfs -u -t -k all
sudo update-grub


Never used sounds, but some desktop's config tools have option to enable sounds, I think.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Lia

That fixed the "Set the RESUME variable to override this" message which was showing up when updating initramfs. :) Thanks

What desktop config tools would those be? I installed dconf-editor and changed the default to the new sound scheme, but that didn't do it.

pavroo

If I remember well, MATE desktop has Control Center-> Sound Preference.
Should check other desktops too.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Lia

Confused.. what should I install or do?

And how does the Custom Startup Services apps work? I want to add a script which should load at startup but not right away with 5s delay. This is how it looks currently. https://i.imgur.com/XeV52zN.png

pavroo

Maybe let me know what is your present desktop, so I will check...

The custom autostart tool is simply to use:
- right click to add a new item
- double click on a command line to change a command
- double click on a Notes line to change it, etc

What do you want to add to your startup?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Lia

#10
LXDE SparkyLinux Nibiru and I want to refresh lxde panel right after restart coz it's a little buggy, the icons on the panel at start up start using the system theme whereas I am using solid color with opacity, so I searched and found this command "lxpanelctl restart" and it fixes it but I hate to have it run manually after every time I log on.

Why you asked about the desktop, I am using the one that comes in default with sparkylinux? LXDE+PCmanFM window manager. This one: https://i.imgur.com/txAzPeV.jpg

pavroo

1. Create lxpanel restarting file in your home dir, for example:
nano .lxpanel-restart
Add to the file:
#! /bin/bash
sleep 5
killall -9 lxpanel
lxpanel &
exit 0

chmod it:
chmod +x .lxpanel-restart

2. Create desktop file in your autostart dir:
nano .config/autostart/lxpanel-restart.desktop
Add to the file:
[Desktop Entry]
Name=LXpanel-Restart
Exec=/home/YOUR-NICK/.lxpanel-restart
Terminal=false
Type=Application

change "YOUR-NICK" to your user name.
Use any text editor instead of nano if you'd like.
Should start working after next log in.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Lia

Done the above steps and rebooted and the icons are fine now :) so I guess it's working fine.

Thanks so much!

View the most recent posts on the forum