Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum


Started by dhinds, August 11, 2017, 06:59:54 PM

Previous topic - Next topic


The main desktop machine has an nvidia graphics card and is using the X.Org X server -- Nouveau display driver.

However:  Some web browers (i.e. Qupzilla and Otter) crash on opening and I've been told that this is common using the Nouveau display driver.

Is there a reason why I should or shouldn't use the non-free NVIDIA drivers instead?

Some browers (slimjet, dillo and vivaldi) are working fine with the Noveau driver.


The problem is not limited to certain browsers.  A recent upgrade for Thunderbird affected the display profoundly, to the extent that Thunderbird is not usable.

So I installed Sea Monkey and am using it's mail application, albeit with some loss of functionality.

That's why I want to try running the right non-free video driver, but I'm aware that I if I get it wrong the display could become totally unusable.  That's why I asked.

What I have installed is an NVidia GeForce GTS250 GPU.

So no one here uses the non-free nvidia drivers?


Fortunately, an update to Thunderbird became available and installing it resolved the video issues that had arisen there.


Sparky's Forum used to be very helpful.


Sorry my friend, if I have nothing to say or help I say nothing.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Hi! there everyone, I've posted a query something about Nvidia driver almost a month now but seems nobody bothers to say a word. My issue is about, after installing Nvidia driver VLC won't work, prior to that using the Nouveau driver it's working perfectly and without any issue at all. I've reinstalled Sparky 4.6.1 a couple of times the same outcome. My other distros MX-16 it's also based on Debian (Jessie) no problem vlc works just fine, only Sparky 4.6.1 stable and Sparky 5.0 testing (just installed the other day) have problem with VLC not working. So i downloaded SM player works just fine. Com, spec. dual core 3.06 ghz, ddr3 6gigs, Nvidia GT630/2g. I'm pretty sure Nvidia driver kills VLC......thanks have a great day to you all! 


"VLC won't work" and "VLC not working" aren't very descriptive; what messages appear when you try and run vlc clip-name from the command line? Reinstalling something cannot be the answer every time because you never really figured out the root cause in the first place.

Like pavroo, if he knows little about the problem, he won't add to the post. I cannot help if I don't know what's broken. But describe it better (the hardware info you've provided is a good start) and the rest of us might pitch in our ideas, to move it along.

nvidia has always been my preferred graphics chip, in any case, and I've always lurked in IRC for issues like these-- to see what other trouble shooting attempts are worthwhile. Have an excellent day


Just installed Sparky GameOver edition here and am working on switching over to non-free drivers.

What is the preferred method of installing NVIDIA drivers in this distro?  I tried to use the graphical tool provided, but that gave me some message about rebooting due to the free drivers still being present. After rebooting the NVIDIA driver was not active. I ended up digging in a bit deeper and still haven't found a solution.

It appears that there's a problem loading the kernel module, but it's not being very explicit in what the error is:
Jan 02 13:18:02 hostname systemd-modules-load[279]: modprobe: FATAL: Module nvidia-current-modeset not found in directory /lib/modules/4.14.0-10.1-liquorix-amd64
Jan 02 13:18:02 hostname systemd-modules-load[279]: Failed to insert 'nvidia_drm': Operation not permitted
Jan 02 13:18:02 hostname systemd-modules-load[279]: modprobe: FATAL: Module nvidia-current-drm not found in directory /lib/modules/4.14.0-10.1-liquorix-amd64
Jan 02 13:18:02 hostname systemd-udevd[308]: modprobe: FATAL: Module nvidia-current not found in directory /lib/modules/4.14.0-10.1-liquorix-amd64

I ended up purging this (`apt-get purge nvidia.`) and then tried the NVIDIA provided installer: ``

Unfortunately I'm running into problems there as well.  Neither the DKMS nor the straight insertion technique work. Log output for the latter:

Any thoughts here? It appears that getting native / non-free drivers from NVIDIA to work either the "Debian way" or the "NVIDIA way" are just failing left and right...

FYI, I am using the Liquorix kernel as well.


I suggest to check on Debian's default kernel.
The driver can be installed as Debian's wiki says:
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Quote from: pavroo on January 03, 2018, 01:20:51 AM
I suggest to check on Debian's default kernel.
The driver can be installed as Debian's wiki says:

That is true, I had some problems with Nvidia drivers as well, every kernel update, to be more specific. The way I solved was to boot over emergency mode and than proceed to the install. For some strange reason, with the DE opened it never compute the dkms package installation.
"Great spirits have always encountered violent opposition from mediocre minds."
Albert Einstein

View the most recent posts on the forum