Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Lenovo Z-50

Started by yaqiao, July 04, 2017, 12:27:58 AM

Previous topic - Next topic


Good morning:

I have installed Sparky on one of 3 computers and enjoy it tremendously.  I will install on another computer soon when gf backs up her data.

However, I am wondering about my main machine, Lenovo z-50.

The specs are as follows:

Kernel: 4.7.0-0-MANJARO x86_64 (64 bit gcc: 6.1.1)
Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: Manjaro Linux
Machine: System: LENOVO (portable) product: 80EC v: Lenovo Z50-75
Mobo: LENOVO model: Lancer 5B3 v: NO DPK
Bios: LENOVO v: A4CN34WW (V 2.03) date: 12/16/2014
CPU: Dual core AMD FX-7500 Radeon R7 10 Compute Cores 4C+6G (-HT-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 8387
clock speeds: max: 2100 MHz 1: 1100 MHz 2: 2100 MHz 3: 1300 MHz
4: 1900 MHz
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R6/R7 Graphics]
bus-ID: 00:01.0
Card-2: Advanced Micro Devices [AMD/ATI] Jet PRO [Radeon R5 M230]
bus-ID: 01:00.0
Display Server: X.Org 1.17.4 driver: radeon
Resolution: 1920x1080@60.01hz
GLX Renderer: Gallium 0.4 on AMD KAVERI (DRM 2.45.0 / 4.7.0-0-MANJARO, LLVM 3.8.0)
GLX Version: 3.0 Mesa 12.0.1 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
driver: snd_hda_intel bus-ID: 00:14.2
Card-2 Advanced Micro Devices [AMD/ATI] Kaveri HDMI/DP Audio Controller
driver: snd_hda_intel bus-ID: 00:01.1
Sound: Advanced Linux Sound Architecture v: k4.7.0-0-MANJARO
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8168 v: 8.040.00-NAPI port: 1000 bus-ID: 02:00.0
IF: enp2s0 state: down mac:
Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
driver: ath9k bus-ID: 03:00.0
IF: wlp3s0 state: up mac:
Drives: HDD Total Size: 1000.2GB (5.7% used)
ID-1: /dev/sda model: WDC_WD10JPCX size: 1000.2GB
Partition: ID-1: / size: 917G used: 54G (7%) fs: ext4 dev: /dev/sda2
ID-2: /boot size: 247M used: 76M (33%) fs: ext2 dev: /dev/sda1
Sensors: System Temperatures: cpu: 42.8C mobo: N/A gpu: 42.0,N/A
Fan Speeds (in rpm): cpu: 0

I ask because I have tried several distros over the past year.  Ubuntu was constantly freezing.  Fedora was okay.  Majaro seems most stable, but occasional problems of freezing.  The problem is the computer not Linux!  There are many posts everywhere about people having Linux issues with the z-50 model

I would love to install Sparky, but I am not sure the effort will be worthwhile.  I tried the live installer and soon noticed a "failed to load module Radeon" message.  Once running it seemed to only detect the Kaveri graphics chip.
I know dual graphics are very problematic, and I would not recommend this computer to any Linux user.

Does anyone have any experience with Sparky/Debian on this machine?  It would be wonderful to have Sparky installed.



I don't have that HW but maybe some distro could work with it; try booting live with the boot parameter radeon.modeset=1 and see if it makes a difference. There are some distros that will show a little more given the right startup options

View the most recent posts on the forum