Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

{SOLVED] The method driver /usr/lib/apt/methods/https could not be found

Started by MaMu, March 07, 2015, 08:02:48 PM

Previous topic - Next topic


Hi all,

I am new to both Linux and forums, and very good in messing everything up.
SparkyLinux has worked fine on my old PC and I have manage it somehow for a year until now.
To this point I have had no problems using Synaptic nor Sparky-APTus. But now I get an error message, when the packages should be downloaded, saying the file from the  repositories could not be downloaded and Not Found.

Then I tried upgrade via Sparky-APTus and got the same kind of answer. All the addresses of the repos seemed to be there.

Then I read about the new sparky-aptus-upgrade package and tried to install it using terminal : sudo apt-get update and got the output :

E: The method driver /usr/lib/apt/methods/https could not be found.

N: Is the package apt-transport-https installed?

...and I could see the package in Synaptic,  and tried installing it and the output was this:

W: Tiedostoa ei voi noutaa
  404  Not Found

....saying: Couldn't get the file..

I have SparkyLinux, MATE on a 32bit intel machine.

Hope somebody can help with this problem


The package "sparky-aptus-upgrade_0.1.12_all.deb" is deprecated, you can't install it from sparky repos.
The latest version is 0.1.13-1
Refresh package list every time before installing or upgrading packages:
sudo apt-get update
or via "Refresh" Synaptic's button or via Sparky APTus-> Updates and Upgrades-> Refresh package list button.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Hi pavroo,
Thanks for your reply. Yes, I've tried all that once again but when reloading I get this:
Could not download all repository indexes      and,
The method driver /usr/lib/apt/methods/https could not be found.

From terminal :~# sudo apt-get update,  this:

E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

I would like to install apt-transport-https, because it is not installed. But I always get the answer :
W: Failed to fetch
  404  Not Found [IP: 80]

what should I try to do next?


It's unusual.
apt-transport-https is required to download packages using secure protocol HTTPS.
You are using HTTP so you don't need it.
Package apt-transport-https_1.0.9.6' is deprecated (again) because the latest version is
Your package manager can't refresh package list for some reasons, but don't know why.
Have you made and changes in repository list? Have you added a new 3th party repository?
Show me your package list:
cat /etc/apt/sources.list
ls -l /etc/apt/sources.list.d
cat /etc/apt/preferences
ls -l /etc/apt/preferences.d

Ping to the main server:
ping -c 3
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Hi again,
yes I did add one to the list in synaptic, -the helineva-list .

root@medion:~# cat /etc/apt/sources.list
deb testing main contrib non-free
deb-src testing main contrib non-free
deb testing/updates main contrib non-free
deb-src testing/updates main contrib non-free
deb testing main non-free
# opera web browser
deb stable non-free
# google-chrome web browser
deb stable main
# mate
deb jessie main
# sparky
deb testing main
# boot-repair
#deb precise main
#deb-src precise main
# sid
#deb sid main contrib non-free
#deb-src sid main contrib non-free
#deb sid main non-free

root@medion:~# ls -l /etc/apt/sources.list.d
total 24
-rw-r--r-- 1 root root 45 Aug  6  2013 dropbox.list
-rw-r--r-- 1 root root 39 Feb 17 00:12 helineva-net.list
-rw-r--r-- 1 root root 45 Feb 17  2013 playonlinux.list
-rw-r--r-- 1 root root 45 Feb 17  2013
-rw-r--r-- 1 root root 55 Feb 10 16:15 ria-repository.list
-rw-r--r-- 1 root root 55 Feb 10 16:15

root@medion:~# cat /etc/apt/preferences
Package: *
Pin: origin
Pin-Priority: 700

root@medion:~# ls -l /etc/apt/preferences.d
total 0

root@medion:~# ping -c 3
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=44 time=311 ms
64 bytes from ( icmp_seq=2 ttl=44 time=311 ms
64 bytes from ( icmp_seq=3 ttl=44 time=311 ms

--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2202ms
rtt min/avg/max/mdev = 311.618/311.701/311.816/0.463 ms

That /https error bathers me also and been reading about this and check from my other computer also with sparkylinux where it shows only some error about ../http.
I found I also have an error with java:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x0954f56c, pid=3839, tid=2995984256
# JRE version: OpenJDK Runtime Environment (7.0_65-b32) (build 1.7.0_65-b32)
# Java VM: OpenJDK Client VM (24.65-b04 mixed mode, sharing linux-x86 )
# Derivative: IcedTea 2.5.3
# Distribution: Debian GNU/Linux unstable (sid), package 7u71-2.5.3-2
# Problematic frame:
# C  0x0954f56c
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:

any ideas ?


The first idea:
Manually download and install 'apt-transport-https' package from the site:
Then refresh package list and try to make upgrading again.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Ok, I will try that,
I have all the dependency files with right versions on my machine, but my libapt-pkg4.12 (>= is an older version, so how shall I update this. (I guess it must be done first because of the error: Dependecy is not satisfiable.)
I do not want to mess up more using a wrong command or file name ,  so how exactly should I do?


Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks pavroo,

Manually down loading and Installing apt-transport-https and all dependencies fixed the problem.
Now I am able to fetch the packages via package manager.

Thanks again.


Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]

Yashendra Goyal

Could you please tell me how to manually download apt-transport-https

View the most recent posts on the forum