Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[solved] sparky not loading after upgrade

Started by eesh, July 08, 2017, 08:29:20 PM

Previous topic - Next topic


After upgrade sparky is not loading - stuck in blue welcome screen with the progress indicator moving. xfce desktop is unreachable.
I tried in grub advanced options - recovery mode: journalctl -xb gives in last line:
received SIGRTMIN+21 from PID 128 (plymouthd).
How can I recover sparky?


Try to load the system with no splash (plymouth).
To do so, when the GRUB screen shows up, press "e" key (to edit), go to a line starting with:
linux      /boot/vmlinux...... ro quiet splash
delete 'splash', then press F10 to load the system.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


This gives me a lot of failures:
failed to start login service
failed to start accounts service
failed to start modem manager


Looks like the upgrade went wrong.
I suggest to:
1. run the system in failsafe mode and try to fix it:
dpkg --configure -a
apt install -f

2. If no changes, re-install the system and make manual upgrade after the first run:
sudo apt update
sudo apt full-upgrade
sudo dpkg --configure -a
sudo apt install -f
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


dpkg --configure -a helped.

Doceniam twoje wsparcie.

View the most recent posts on the forum