Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[Solved] Java Issue

Started by ow346, May 14, 2017, 04:55:45 PM

Previous topic - Next topic

ow346

So i just downloaded and installed sparky to try out a new OS meant for gaming, (I've been using puppy Linux and ubuntu in the past) I really only play Minecraft and I cannot seem to figure out how to set the jar file to execute, I've opened the properties window to try and set the program that the jar file would be opened with, but the only thing that relates to Java that i can see is the "open JDK Java 8 policy tool"
please help , I'm not really good with this sort of thing and a Google search does not really pop up anything that is useful to me

pavroo

#1
1. Create openjdk.desktop file in your home's local directory:
~HOME/.local/share/applications/openjdk.desktop
Paste into the file:
[Desktop Entry]
Name=OpenJDK
Comment=OpenJDK Java
Exec=java -jar
Terminal=false
Type=Application
Icon=openjdk-8
Categories=Settings;


2. Edit or create (if not exist) mimeapps file in your home dir:
~HOME/.config/mimeapps.list
Add the line to the file, in sections [Default Applications] & [Added Associations]:
application/x-java-archive=openjdk.desktop;
make sure there is not other lines beginning with:
application/x-java-archive=

3. Update menus via the command:
update-menus

4. Open a file manager, go to your *.jar file, then open it with "OpenJDK".
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ow346

Thank you so much! Your help is much appreciated  ;D it worked.

paxmark1

Please edit your initial subject line  and add Solved to the beginning.  peace out.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum