Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

New user; Steam issues on gameover edition

Started by AtomicPotato, February 26, 2017, 06:45:09 AM

Previous topic - Next topic


So, of course I'm really new to Linux and I don't know what's wrong.

Everytime I try to start Steam from LXTerminal, icon, various commands or anything like that it won't start. That's one of the main reasons that I decided on the gameover edition, that it came with Steam already installed.

When I run "sudo -u zack steam" (zack is my username) the following code comes up:

Running Steam on sparky 4 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver:
libGL error: failed to load driver: swrast

I have tried installing every driver recommended for my GPU and nothing has helped. Any help would be much appreciated


What is your steam version? Show me:
apt-cache policy steam
apt-cache policy steam-launcher
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I'm having the exact same issue, to be sure I also uninstalled the version that came with Sparky and downloaded the latest version of Steam from the official site.
I have replicated the command in terminal and have the exact same error.

I installed Sparky just yesterday and there are a few minor issues I have with some minor display things, but having Steam able to run is very important to me.
So the sooner this issue is sorted, the sooner OP, myself and anyone else with the same issue can continue playing Steam.

But yeah, I'll have a go at finding out how i can get these missing drivers in the meantime, but if you find an effective solution please tell, thanks in advance.


After searching on these forums for solutions to the steam issue and other research, I found that there is a driver metapackage that needs to be downloaded through Synaptic Package Manager called simply as "nvidia-driver"

After the long installation of it I rebooted my PC, what resulted stunned me and I was this close to giving up on Sparky as an operating system. It had booted up without my application icons on my taskbar, no files on the desktop, i could run terminal but not root terminal as it bugged out gsku. And on top of that, nothing could be edited because the system was deemed as a "read-only system". Nothing was working, not even Firefox.

But I decided to reboot once more just to see if there was still a chance it'd recover. and now it works fine and now steam is working! ^-^

Note: I've noticed a very significant black screen time after GRUB with this extra driver installation, so don't let that trouble you, your PC probably isn't frozen or not going to load, it's just going to take it's time.

EDIT: Seems this "read-only system" problem is occuring occasionally on boot now, I'll need to make a new thread on it..

View the most recent posts on the forum