Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Gnome Policykit changed again

Started by pavroo, January 25, 2017, 09:49:01 PM

Previous topic - Next topic

pavroo

As I posted somewhere about changing the Gnome policykit patch before, it happend again.
It means, Debian devs revert the patch back to the old one.

So, if you use tiny window managers, installed via Sparky APTus-> Desktop tool, or via Sparky minimal iso - you should change the policykit command, stored in the wm startup script, from:
/usr/lib/polkit-gnome-authentication-agent-1
to:
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
It happens in the mw's: awesome, bspwm, enlightenment, fluxbox, i3, icewm, jwm, openbox, pekwm, trinity, windowmaker.

Otherwise, upgrade your system and re-run APTus-> Desktop-> your desktop icon to make it easy.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat


pavroo

#2
To avoid similar problems in the feature, I created a small tool called 'sparky-polkit'.
It uses Gnome Policykit or Lxpolkit to provide the authentication agent to tiny window managers supported by Sparky.
It also let me fix any similar problem in the future, without the end users manual fixing, by a regular update channel.

It also doesn't make conflict with a default's desktop environment polkit. For example, if you have a few desktops installed, such as Xfce,  LXDE, GNOME, etc. and a window managers such as: Openbox, Fluxbox, JWM, etc., my script check is a polkit backend running or not.
If yes - just quit.
if no - runs Gnome Policykit or LXpolkit, depends what is installed.

It's coming to repos now.   
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum