Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[SOLVED]: WiFi won't work after LXDE upgrade..

Started by scdas141, January 20, 2017, 03:20:55 PM

Previous topic - Next topic


Hey guys..

My system info..

Kernel:      Liquorix 4.8.0-15.1-amd64
Desktop:   Openbox

I have the TP-LINK TL-WN823N Wifi Adapter for which I am using the Github repo drivers at .. Everytime I upgrade I have to re-compile the package using 'make && make install' but any upgrade above Liquorix 4.8.0-15.1 renders my WiFi useless.. Even re-compiling the driver package doesn't help..

Btw, the TP-Link TL-WN823N is based on the Realtek RTL8192EU chipset.. Any help will be appreciated..

PS. Are there any of you who have faced Wifi driver issues after upgrading.. ?


If inxi is installed, please post "inxi -n"    Post "apt-cache policy wpasupplicant"  (was a bug in sid there)    Also would not hurt  to post via root or via sudo  your iwconfig output.  NOTE: the naming conventions have changed - what was wlan0 is now a longer string and more specific. 

post "sudo iwconfig wlan0" works for older naming conventions.  Whatever follows "IF:" in the inxi -n output for wireless is what you type in after sudo iwconfig 

Side issue - is there a reason why you are not using the Debian drivers and your are compiling them in the first place. Posting why might help others. Similar - using the Debian kernel gives you more people with the same kernel experiencing the same bug.  If you suspect a Liquorix kernel problem, check Liquorix irc and web sites.

Ruthless bug squashing now occurring in Debian testing presently as new programs will soon be frozen from entry. The kernel for Debian is being gone over with a fine tooth comb presently.    But first, post what you can.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Hey Pax, Thanks for the reply..

A few issues..

1. The "firmware-realtek_20161130-2_all.deb" package installs okay but simply won't make my wifi work..

2. Any no. of times I have upgraded, I haven't found a single fault in the compilation of the GitHub RTL8192EU package.. but as soon as I upgrade to Liquorix 4.9.x , I find an error in the compilation itself.. something about "Incorrect If and fi arguments.. etc etc.."

Now I have reverted back to Liquorix 4.8, as I simply loose wifi connectivity after the upgrade..

Here are the posts u requested for my stable 4.8 kernel..

A. "inxi -n"..

B. "apt-cache policy wpasupplicant"..

C.  "iwconfig"..

PS. I can post the results of compiling the driver package after upgrading to 4.9.x but it will take me about a couple of hours or more to recover and post..

Thanks again..


I very rarely will reply to screen shots.  Please post via the xml code tags. You can use the # gui button.  Ctl-Shift-C will copy from the terminal
wpasupplicant version that has grave bugs is 2.6.2   So you are o.k. in that regard  Bugs849122 and 8490787;package=wpasupplicant#_0_1_1

I was expecting inxi -n to show your wlan  What is interesting is that your ethernet state is down  Please post output of "lspci"

The iwconfig shows a good strong connection but no data being exchanged.  I would not know if the @ in the nickname would cause problems.  Probably not. (I cannot paste WIFI@REALTEK from a picture - why I dislike screenshots)

Compiling the driver versus using the Debian binary.  Is your wlan chip so very very new that it is not serviced via Debian (and probably other versions of linux)? Sparky by default has contrib and non-free in the etc/apt/sourcelists that point towards Debian and provides them with the install iso. 

Have you seen   I see via the
QuoteRTL8192U-based devices only: firmware is required to be manually supplied:
that apt-get update and apt-get install firmware-realtek does not work for that particular dongle.  (For usb dongles and linux - I like Hawking)  Also for the future -   is a good reference. 

Have you ever tried the wget version of the Realtek blob as in the 8192 wiki page.  Compiling can be tricky and I avoid it like the plague now. 

paxmark@raunes:~$ inxi                                                                                                                 │
CPU~Dual core Intel Core i3-4170 (-HT-MCP-) speed/max~2599/3700 MHz Kernel~4.8.0-2-amd64 x86_64 Up~12:32 Mem~825.0/7446.4MB HDD~2000.4G│
B(26.2% used) Procs~173 Client~Shell inxi~2.3.5

shows that I am using the debian kernel on this machine. From other forums and #debian-next I do know that a few are having problems with the 4.9 versions in unstable. 

My hobbyist viewpoint is that since the 8192 has worked for others in Debian-Stable-Jessie that older kernels (i.e. 4.8) should work in our Sparky derivative version of Debian-Testing-Stretch.  If your liquourix 4.8 kernel works, keep using it until a solution presents itself.  Others might have more info.  Keep digging further on the web especially words like 8192CU  linux  debian, etc.  Peace out.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Hi pax, Thanks again..

Pardon me for being a newb, but I could'nt get the # gui or ctrl-shift-C

I was thinking screens would be better since they reproduce the exact outs including error color-codes..

Here are the inxi, wpasupplicant and iwconfig outputs respectively..


root@ik--pc:/home/ik# inxi
CPU~Dual core Intel Core2 Duo E8400 (-MCP-) speed/max~2003/3003 MHz Kernel~4.8.0-15.1-liquorix-amd64 x86_64 Up~26 min Mem~815.2/3945.3MB HDD~670.2GB(3.2% used) Procs~179 Client~Shell inxi~2.3.5


I think u have already gone thru the earlier output-screens, so I will just post the compile error code for 4.9.x, see if u can spot anything if u would indulge me one last time reg screenshots..



Thanks again..

PS sorry I had recorded the compile errors as screenshots.. :-(


I hope you are still getting things the way you like. 

If you are new, there are many easier things than compiling to learn and master that are also more important in Linux, Debian and Sparky.  As I posted

The ability to cut and paste from gui (browser, editor, etc.) to the command line on the terminal is crucial.  Terminals and  consoles, have one extra keystroke.  To copy from a console is Ctl-Shift-C - pressing down the Ctl key, the Shift key and the "C" key all at the same time.  To paste into a console or terminal is Ctl-Shift-V  So -- from the above wiki page

# apt-get install unzip && exit
$ wget
$ su
# mkdir /lib/firmware/RTL8192U
# cp rtl8192u_linux_2.6.0006.1031.2008/firmware/RTL8192U/* /lib/firmware/RTL8192U

You can copy each line, one at a time from here and paste into your console. That saves typing and avoids typing errors.  I have personally tried the first two lines.  The wget link to Dlink is good  and the .ZIP unzips . 

Try that instead of compiling.  The Debian wiki specifically says that apt-get install firmware-realtek will not work with your specific dongle. 

And, if it does not work,  just remove the directory that you made - RTL8192U 

peace out.


Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Hey everyone..

I managed to solve the issue..  Thanks a million to thamer from Github.. :D :D

Just adding "8192eu" via text editor to "/etc/modules" and recompiling the driver did the trick..

I have seen many people report wifi connection problems after upgrading to kernel 4.9.x, especially with Realtek wifi chipsets..

I have managed to find a solution, thanks to thamer from Github..

Actually this is a driver issue.. The 4.9.x kernel for some reason is unable to use the correct 8192eu driver.. instead it is using the rtl8xxxu driver..

If you run "lshw -c network" from a root terminal, you can clearly see it is using a different 81xx driver..

So to solve this:


Open "etc/modules" from a file manager (Nautilus, PcManfm, etc..) as root..

The "modules" file just contains a single entry "loop".. Add an entry "8192eu" before the loop as shown below:

What this does is manually pre-loads the 8192eu module during boot..


Recompile the driver using "make && make install" from a root terminal and reboot..

Viola!! You'll have the driver working again.. I have checked this multiple times and have been satisfied this works every time..


Actually, I have put together a tutorial for new users or people looking for detailed information on how to compile the Github driver..

Hope this helps..

Thanks again, everyone -- especially paxmark who tried to help.. 

PS. Request to moderator to mark it as solved..

View the most recent posts on the forum