Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Flash player for Firefox & Chromium

Started by leGarde, January 09, 2017, 07:46:59 PM

Previous topic - Next topic


Hi! My browsers told me that i need Flash player 10 or better to be able to use some online-apps.
Shouldn't Firefox & Chromium got built-in Flash player? Anyway my browsers don't. So how can i solve this problem (without installing Chorme).
NB: in case of newbie I'm not a hard linux user that why I need step by step manual.


Noter:  contrib and nonfree need to be in /etc/apt/sources.list
As root in terminal (or use sudo in terminal)

'apt install flashplugin-nonfree'

to update

"update-flashplugin-nonfree -iv" 

to see what the -iv means, - read "man flashplugin-nonfree"

That gets you the old proprietary Adobe flash on your system.  Note Adobe stopped all support except security for flash in linux.  See  Search firefox npapi

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Hi leGarde, and welcome to Sparky. :)

Uhoh, Flash... well that is a red and irritated sore point. I am not sure if I can help you any more than paxmark1 already have done. I will give you the link to the Debian wiki of course, but doubt that you will feel helped by that. But I `ll do it anyway ;D

My suggestion is that you sit down and take a really hardcore Google session about Flash Player, Linux, Debian  etc... to collect information about it, to sort of understand how it works in Linux in general, and Debian in particular. I have Googled a bit, but mostly it is about how to install it on different distros. Not much about how it works, and why it works, or rather not works. I am pretty sure that the information is out there, just me that did not search long and hard enough. :)
Unstable OpenBoxer


Thanks guys for answering and welcoming   :)
I was expecting this problem to be solve by few simple terminal commands.
But now i see that's more complicated than i expect, and needs many time for hard searching and understanding. I don't have enough time for that at this moment. In my case avoiding problem is more helpful, than that cracking ???
For the future, if I'll find method, it will be post here ;)


Quote from: paxmark1 on January 10, 2017, 12:07:49 AM
Noter:  contrib and nonfree need to be in /etc/apt/sources.list
My <sources.list>
deb testing main contrib non-free
deb-src testing main contrib non-free
deb testing/updates main contrib non-free
deb-src testing/updates main contrib non-free
deb testing main non-free

## Other repos can be found in /etc/apt/sources.list.d directory ##

Quote from: paxmark1 on January 10, 2017, 12:07:49 AM
As root in terminal (or use sudo in terminal)

'apt install flashplugin-nonfree'

Time to rise up!
At chrome://plugins/ i make sure that my Chromium  have pepper flash:
@Adobe Flash Player - Version: 11.2.999.999
Shockwave Flash 11.2 r999
Name:   Shockwave Flash
Description:   Shockwave Flash 11.2 r999
Version:   11.2.999.999
Location:   /usr/lib/pepperflashplugin-nonfree/
Type:   PPAPI (out-of-process)
MIME types:   
MIME type   Description   File extensions
application/x-shockwave-flash   Shockwave Flash   
application/futuresplash   FutureSplash Player   
Disable   Always allowed to run@

Now my web-pages ask me to allow them using that plug-in (when Always allowed to run is enable). Any try is do nothing.
At first i tried to right-clicking then Run this plug-in, but nothing happens.Than i tied push other menu buttons with same result.
Moment 2.  when Always allowed to run is disable Chromium think that he's don't have any flash, like begins of this topic.
Have any idea?=)

View the most recent posts on the forum