Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Sparky APTus cannot be opened

Started by Goofy, January 01, 2017, 05:46:52 PM

Previous topic - Next topic


The file '.su-to-rootrc' does already exists. It contains one line exactly with 'your' code: SU_TO_ROOT_SU=sudo

The output from the command 'gksu -d sparky-aptus' is:

goofy@pc01goofy:~$ gksu -d sparky-aptus
xauth: -e0f5e98b1c4d8a0b6fb7b7f2a4492388
display: -:0.0-
final xauth: -e0f5e98b1c4d8a0b6fb7b7f2a4492388
final display: -:0.0-
STARTUP_ID: gksu/sparky-aptus/1838-0-pc01goofy_TIME139252
gksu_context_run: buf: -Passwort: -
no password on keyring
DEBUG (run:after-pass) buf: -Passwort: -
-EBUG (run:post-after-pass) buf: -
-EBUG (run:post-after-pass) buf: -su: Fehler bei Authentifizierung
-EBUG (auth_failed) buf: -su: Fehler bei Authentifizierung

It's strange that the output says, that there is no Password on keyring in spite of the fact, that I have done exactly this: The command 'gksu -d sparky-aptus' asks for this password, which I must given.

The output from the command 'gksudo -d sparky-aptus' is:

goofy@pc01goofy:~$ gksudo -d sparky-aptus
No ask_pass set, using default!
xauth: /tmp/libgksu-1Ya105/.Xauthority
STARTUP_ID: gksudo/sparky-aptus/2105-0-pc01goofy_TIME1166664
cmd[0]: /usr/bin/sudo
cmd[1]: -H
cmd[2]: -S
cmd[3]: -p
cmd[5]: -u
cmd[6]: root
cmd[7]: --
cmd[8]: sparky-aptus
brute force GNOME_SUDO_PASS ended...
Yeah, we're in...
xauth: /tmp/libgksu-1Ya105/.Xauthority
xauth_env: /home/goofy/.Xauthority
dir: /tmp/libgksu-1Ya105

My attempts show that it is a general problem: Almost all system-tools from the desktop-menu are concerned. I cannot open these from the Menu.


Show me:
ls -l $HOME/.Xauthority

Anyway I suggest to try to clean up the file:
mv $HOME/.Xauthority $HOME/.Xauthority.bak
touch $HOME/.Xauthority

then reboot.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


The answer from the command 'ls -l $HOME/.Xauthority' is:

goofy@pc01goofy:~$ ls -l $HOME/.Xauthority
-rw-r--r-- 1 goofy goofy 54 Jan  4 06:54 /home/goofy/.Xauthority

I have tried

mv $HOME/.Xauthority $HOME/.Xauthority.bak
touch $HOME/.Xauthority

and reboot, but it changes nothing.


Hello pavroo,

now I observed a new problem: I wanted to start APTus via the LXTerminal with (like at the beginning of our discussion)

goofy@pc01goofy:~$ sudo sparky-aptus
[sudo] Passwort für goofy:

but I cannot type the password anymore, because there is no reaction to my keyboard inputs. I have reboot but it stills the same.
Can it be, that something of the last inputs has changed something important?


I have no more ideas by now, I only suggest to make fresh installation.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I second that. Have read the whole thread, and nothing comes to mind.

Goofy, have you done any other changes or configurations to your system that is not mentioned in this thread?
Unstable OpenBoxer


Hello pavroo, thank you very much for your time!
Hello blaze, thank you for your concerning...

No, I have made no changes, exept ot install Libre-Office or the Ryzom-Client. But this problem existed from the beginning. Only I have not recognized it. When I ran "Sparky-First-run" the first one, I thought this was normal, that I have seen nothing; Nothing means exept the small stopwatch and something like in the background is opened a window, which I could't  see, because all is clear.

As I started then these processes like APTus und the Sparky-First-Run from the LXTerminal, I have seen what would have had to happen.

Yes, I think also that a new installation, would be the best. But which one should I take? I think perhaps it is problematically, because I used the 64-bit version? -A test before offered that my i5-CPU could do it... ...but mayby not? Or another component in my Computer doesn't like 64bit and then the Sparky is crashing?

Likely I would have to try both to be sure...     :'(


ok, now I have made a new installation of Sparky-64-bit version and...
...all is ok!     ;D

Now I know what was wrong:

Pavroo supposed the mistake at the correct place: It was a Problem with the passwords.

At my first installation the Sparky-installer asked me for a password for the admin; (It must have been so, because I noted it on a paper...) When I have started now APTus or another system -tool, the system asked for the admin-password; And I typed it in and nothing is happened...

By the three installations which I have done afterwards, were no demands for a admin-password. -And so I gave the system my user-password (in those dialogs, where the system needs the admin-password) and all is going fine.

The question is now, should I change this and create a seperatly password for the admin?


Well Goofy... sometimes... ;D

About the password, do as what fits your personal situation. :)
Unstable OpenBoxer


Type "man passwd"  Read.  Act accordingly.  Peace out.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum