Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

sparky installer hangs after first selection screen

Started by arkanex, June 02, 2016, 06:30:47 PM

Previous topic - Next topic


After selecting username and password. I click forward.. Just sits there.  I open up a terminal and kill the gksudo process for the installer and then it comes to partition selection.  Seems like a small bug


I signed up just to re-report this.
It's happened already 4 times. Re-downloaded the iso (XFCE amd64 if it matters) and the same.
The thing is, that the first ISO, installed just fine a week ago, when there was no other distro in the PC, but I totally messed the network configuration and wiped it off. I then installed Manjaro, configured it to my liking, and then I tried to install Sparky again, but the installer just hangs after the username/passwords selection.

Take care guys.  Looks like a GREAT distro, but (for now at least) its not happening for me. Maybe some help here ?

Thessaloniki Greece


Found the other forum posts with the same issue. It certainly looks like the installer (sometimes ?) doesn't like seeing other partitions. As I said, the same iso installed without problems when it had the whole disk to itself. Downloaded another (random) iso (the LXQT) , just in case. The same thing happened. If it matters, ALL the partitions in that disk are logical, in one (big) extended.

Take care   


Run it in a terminal:
sudo live-installer
to check what is wrong, and find and provide log file stored in /var/log/live-installer.log
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Sorry for the delay. Real life can get in the way.

this is the console output of the installer BEFORE the freeze

Color: #803300, Image: timezone_2.0.png
/usr/lib/live-installer/frontend/ Warning: Source ID 30 was not found when attempting to remove it
  glib.source_remove(self.kbd_preview_generation)  # stop previous preview generation, if any
Excluding /dev/sdd (detected as the live device)
Can't find model in blkid output: ['loop', 'loop0', '0', '1.5G']
Disks:  [('/dev/sda', 'WDC WD20EZRX-00D (1 TB)'), ('/dev/sdb', 'WDC WD5000BEVT-2 (500 GB)'), ('/dev/sdc', 'SAMSUNG HD103SJ (1000 GB)')]
mount: unknown filesystem type 'swap'
No passwd entry for user 'sparky'
No passwd entry for user 'sparky'
mount: special device /dev/sdb-1 does not exist
df: /dev/sdb-1: No such file or directory
WARNING: Partition /dev/sdb-1 or type 4 failed to mount!
Caution: invalid main GPT header, but valid backup; regenerating main header
from backup!

Warning! Main partition table CRC mismatch! Loaded backup partition table
instead of main partition table!

Warning! One or more CRCs don't match. You should repair the disk!

As I already said indirectly, I do NOT have a uefi configuration and am still on an MBR.
live@live:~$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present

Found invalid GPT and valid MBR; converting MBR to GPT format
in memory.

Disk /dev/sda: 3907029168 sectors, 1.8 TiB
Logical sector size: 512 bytes
Disk identifier (GUID): D787BC43-4728-4A06-A21B-96B39C31E671
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 3907029134
Partitions will be aligned on 8-sector boundaries
Total free space is 7923 sectors (3.9 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048       208871423   99.6 GiB    0700  Microsoft basic data
   2       208871424       423911423   102.5 GiB   0700  Microsoft basic data
   3       423911424      1859024895   684.3 GiB   0700  Microsoft basic data
   4      1859025735      3907024064   976.6 GiB   0700  Microsoft basic data

There is nothing wrong with the boot process AFAIK and understand. MX-15 and Debian vanilla installed just fine in the drive.

A few more things.
** I had once only (and could not reproduce it) a screen with errors after quiting the live-installer which were (probably) these.Cannot be 1000% sure but I am pretty confident that they were these.
** The CLI installer had no problem and went into Gparted without any problems
It;s the installer and ONLY MBR configuration.  Or at least it looks like this from my perspective.

Take care and thanks for answering.

PS : there was no /var/log/live-installer.log to include


There is nothing about EFI.
I've seen similar problem on Bios based configurations too, the live-installer related.
I suggest:
Disconnect all not needed disks: you had sda, sdb and sdc connected during installation (live system was on sdd). Keep connected only the one you want to install Sparky to.

If still no luck, try to install the live system using older installer called Advanced Installer.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]

View the most recent posts on the forum