Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

steam help

Started by letmebefrank, October 23, 2016, 03:48:55 AM

Previous topic - Next topic

letmebefrank

Package installer opens says
steam needs to install these additional packages
            python-apt
[sudo] passwoed for .........:
but i cannot type anything

letmebefrank

tryed to install from terminal and got this

frank@main:~/Downloads$ steam
Package python-apt needs to be installed
Running Steam on sparky 4 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

paxmark1

In the future, please post "code" in code mark up or use the '#" button above to format.  It helps us and it looks better

Via command line, type  "sudo apt-get install python-apt"           That should install python-apt. 

To learn, type "aptitude show steam"  and then "aptitude show steam-launch"  .  That will tell you about the transition package and the package that launches steam.  python-apt is listed as a dependency of steam-launch. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

letmebefrank

reinstalled sparky ran upgrade and the tryed to launch steam , got this
$ steam
Running Steam on sparky 4 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

letmebefrank

got it to work with this this
find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

letmebefrank

still has the X Package Install window popping up when i launch, it says

Steam needs to install these additional packages:
        curl, python-apt, xterm, xz-utils, zenity, libgl1-mesa -dri:i386, libgl1-mesa-glx:i386
dpkg:symbol lookup error: dpkg: undefined symbol: setexecfilecon
[sudo] passward for ******:

but like befor i cannot enter anything

pavroo

If steam need them, install them manually:
sudo apt-get update
sudo apt-get install curl python-apt xterm xz-utils zenity libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

But the xterm, xz-utils, zenity are pre-installed as default.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

frank392

I had the same problem, The way I fixed was to install the Nvidia drivers and that fixed the problem with steam by the way the litle app to install the drivers from sparky is not working I used Synaptic

View the most recent posts on the forum