Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

lost sound with recent upgrades 4.7.0-1

Started by galen, November 01, 2016, 11:16:36 PM

Previous topic - Next topic


Oct 31 sound was working,
after a reboot into
4.7.0-1-686 #1 SMP Debian 4.7.8-1 (2016-10-19) i686 GNU/Linux
sound is gone.
Pulsemixer shows output as DUMMY as only selection

#lsmod |grep snd
snd_hrtimer            16384  1
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            24576  1 snd_seq_midi
snd_seq                53248  3 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_hda_codec_idt      45056  1
snd_hda_codec_generic    65536  1 snd_hda_codec_idt
snd_hda_codec_hdmi     40960  2
snd_hda_intel          28672  1
snd_hda_codec          94208  4 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           53248  5 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_pcm_oss            45056  0
snd_mixer_oss          24576  1 snd_pcm_oss
snd_pcm                86016  6 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_timer              28672  3 snd_hrtimer,snd_pcm,snd_seq
snd                    57344  15 snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_mixer_oss
soundcore              16384  1 snd

audio device is Intel 82801H

ideas anyone?

XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness


this also happens with 4.6 kernel

upon shutdown the system notice suggested using
as a kernel boot option.

so far that has worked but only if I remove "splash quiet" and add "irqpoll"

there are still bootup errors such as several this type of warning


3.717464] WARNING: CPU: 0 PID: 717 at /build/linux-zJdjnQ/linux-4.7.8/drivers/gpu/drm/i915/intel_display.c:6333 verify_connector_state+0x2cd/0x370 [i915]
[   13.717467] connector enabled without attached crtc
[   13.717469] Modules linked in: fuse snd_hrtimer snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device bnep binfmt_misc iTCO_wdt iTCO_vendor_support ir_lirc_codec lirc_dev rtl2832_sdr r820t rtl2832 i2c_mux dcdbas dell_smm_hwmon arc4 coretemp pcspkr joydev serio_raw snd_hda_codec_idt dvb_usb_rtl28xxu iwl4965 snd_hda_codec_generic sg dvb_usb_v2 iwlegacy dvb_core uvcvideo rc_core i2c_i801 mac80211 snd_hda_codec_hdmi videobuf2_vmalloc videobuf2_memops option btusb btrtl usb_wwan btbcm r852 btintel sm_common videobuf2_v4l2 videobuf2_core usbserial cfg80211 videodev nand snd_hda_intel bluetooth nand_ecc nand_bch snd_hda_codec bch snd_hda_core snd_hwdep media r592 nand_ids mtd memstick snd_pcm_oss snd_mixer_oss lpc_ich snd_pcm snd_timer rfkill snd soundcore shpchp battery evdev acpi_cpufreq
[   13.717528]  tpm_tis ac tpm loop ecryptfs cbc hmac encrypted_keys parport_pc sunrpc ppdev lp parport ip_tables x_tables autofs4 ext4 ecb xts lrw gf128mul ablk_helper cryptd aes_i586 crc16 jbd2 crc32c_generic mbcache sr_mod sd_mod cdrom ata_generic hid_generic usbhid hid mmc_block ata_piix ahci psmouse libahci libata scsi_mod i915 firewire_ohci sdhci_pci sdhci mmc_core firewire_core crc_itu_t ehci_pci uhci_hcd ehci_hcd thermal i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops video drm button usbcore wmi sky2 usb_common
[   13.717579] CPU: 0 PID: 717 Comm: Xorg Tainted: G        W       4.7.0-1-686 #1 Debian 4.7.8-1
[   13.717581] Hardware name: Dell Inc. Inspiron 1525                   /0U990C, BIOS A17 10/27/2009
[   13.717583]  00200286 98efd599 f10e1ae0 c22d00bc f10e1af4 00000000 c205c16a f855ef34
[   13.717589]  f10e1b14 000002cd f855cd38 000018bd f84dcf3d 000018bd 00000009 f84dcf3d
[   13.717595]  f133a800 f13d27c0 f549aa1c f10e1b00 c205c1d6 00000009 00000000 f10e1af4
[   13.717600] Call Trace:
[   13.717608]  [<c22d00bc>] ? dump_stack+0x55/0x79
[   13.717612]  [<c205c16a>] ? __warn+0xea/0x110
[   13.717633]  [<f84dcf3d>] ? verify_connector_state+0x2cd/0x370 [i915]
[   13.717654]  [<f84dcf3d>] ? verify_connector_state+0x2cd/0x370 [i915]
[   13.717657]  [<c205c1d6>] ? warn_slowpath_fmt+0x46/0x60
[   13.717678]  [<f84dcf3d>] ? verify_connector_state+0x2cd/0x370 [i915]
[   13.717699]  [<f84e7d18>] ? intel_atomic_commit+0xd78/0x1330 [i915]
[   13.717720]  [<f84e8d50>] ? intel_link_compute_m_n+0x60/0x60 [i915]
[   13.717730]  [<f81daa03>] ? vblank_disable_and_save+0x53/0x70 [drm]
[   13.717737]  [<f81daa6a>] ? vblank_disable_fn+0x4a/0x90 [drm]
[   13.717745]  [<f81f42b2>] ? drm_atomic_commit+0x32/0x60 [drm]
[   13.717766]  [<f84ed752>] ? intel_release_load_detect_pipe+0x22/0xb0 [i915]
[   13.717770]  [<c209b500>] ? wake_atomic_t_function+0x70/0x70
[   13.717791]  [<f84bfff0>] ? ironlake_do_reset+0x1a0/0x1a0 [i915]
[   13.717811]  [<f84bfff0>] ? ironlake_do_reset+0x1a0/0x1a0 [i915]
[   13.717830]  [<f852bd07>] ? intel_tv_detect+0x337/0x690 [i915]
[   13.717838]  [<f826fe28>] ? drm_helper_probe_single_connector_modes+0x2e8/0x4d0 [drm_kms_helper]
[   13.717848]  [<f81e20bd>] ? get_properties+0xad/0x100 [drm]
[   13.717856]  [<f81e188c>] ? _object_find+0x5c/0xc0 [drm]
[   13.717866]  [<f81e7295>] ? drm_mode_getconnector+0x285/0x2f0 [drm]
[   13.717870]  [<c2560477>] ? __ww_mutex_lock+0x17/0xa0
[   13.717879]  [<f81e7010>] ? drm_mode_getcrtc+0x140/0x140 [drm]
[   13.717886]  [<f81d9409>] ? drm_ioctl+0x149/0x4f0 [drm]
[   13.717895]  [<f81e7010>] ? drm_mode_getcrtc+0x140/0x140 [drm]
[   13.717899]  [<c2023444>] ? fpu__restore+0x74/0x170
[   13.717902]  [<c2024a83>] ? __fpu__restore_sig+0x213/0x460
[   13.717909]  [<f81d92c0>] ? drm_getclient+0x70/0x70 [drm]
[   13.717913]  [<c21d035c>] ? do_vfs_ioctl+0x8c/0x740
[   13.717916]  [<c21d0a70>] ? SyS_ioctl+0x60/0x70
[   13.717919]  [<c2001b8d>] ? do_fast_syscall_32+0x8d/0x140
[   13.717923]  [<c256256a>] ? sysenter_past_esp+0x47/0x75
[   13.717926] ---[ end trace 7cc9146a3255d543 ]---

XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness



the kernel parameters only worked the first 3 times I tried it.
Several more reboots all have no sound plus kernel errors.
has been edited to include irqpoll
and grub updated

is installed.

I also have Xubuntu16  on the system and it does not [yet?] have these worsening issues.
It has boot up parameters
linux /boot/vmlinuz-4.4.0-31-generic ... ro plymouth:debug splash quiet drm.debug=0xe $vt_handoff init=/sbin/upstart
and the propriatory firmware patches for intel

any ideas?
should I file a kernel bug report?
where is the best place?
XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness


can you post some small information
sparky version (4.4 or similar)
sparky desktop (lxqt, xfce, kde etc)
architecture (32 bit / 64 bit)
soundcard info
video card info

Or if you install inxi you could post the output of inxi -F to save anyone having to ask any other spec questions.


inxi -F
System:    Host: sparky-on-kingston Kernel: 4.7.0-1-686 i686 (32 bit)
           Desktop: LXDE (Openbox 3.6.1) Distro: SparkyLinux Tyche
Machine:   System: Dell (portable) product: Inspiron 1525
           Mobo: Dell model: 0U990C BIOS: Dell v: A17 date: 10/27/2009
CPU:       Single core Intel Core2 Duo T6400 (-UP-) cache: 2048 KB
           speed: 1995 MHz (max)
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.02hz
           GLX Renderer: Mesa DRI Intel 965GM x86/MMX/SSE2
           GLX Version: 2.1 Mesa 12.0.3
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.7.0-1-686
Network:   Card-1: Marvell 88E8040 PCI-E Fast Ethernet Controller
           driver: sky2
           IF: eth0 state: down mac: 00:23:ae:15:ab:66
           Card-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
           driver: iwl4965
           IF: wlan0 state: up mac: 00:21:5c:59:8d:cc
Drives:    HDD Total Size: 135.7GB (64.9% used)
           ID-1: /dev/mmcblk0 model: N/A size: 7.9GB
           ID-2: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB
           ID-3: USB /dev/sdb model: USB_Flash_Drive size: 15.7GB
Partition: ID-1: / size: 15G used: 11G (73%) fs: ext4 dev: /dev/sda4
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A fan-2: 0
Info:      Processes: 179 Uptime: 5 min Memory: 598.8/2010.8MB
           Client: Shell (bash) inxi: 2.3.1
XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness


I have a Dell Inspiron 1545, and will install and test on that, it could be a day or 2 til I can free the machine though as it is currently being used as a PVR and I'll have to work around the recording schedule.


After checking the schedule I had a chance to set this machine up and after installing all updates I tested sound (youtube) and it all appears to be working although my system isn't quite the same as yours.
System:    Host: sparky32 Kernel: 4.7.0-1-686 i686 (32 bit) Desktop: LXDE (Openbox 3.6.1)
           Distro: SparkyLinux Tyche
Machine:   System: Dell (portable) product: Inspiron 1545
           Mobo: Dell model: 0G848F BIOS: Dell v: A14 date: 12/07/2009
Battery    BAT0: charge: 20.0 Wh 511.5% condition: 3.9/20.0 Wh (20%)
CPU:       Single core Intel 585 (-UP-) cache: 1024 KB speed/max: 1000/2167 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express x86/MMX/SSE2 GLX Version: 2.1 Mesa 12.0.3
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel Sound: ALSA v: k4.7.0-1-686
Network:   Card-1: Marvell 88E8040 PCI-E Fast Ethernet Controller driver: sky2
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:23:ae:29:0d:88
           Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: b43-pci-bridge
           IF: wlan0 state: down mac: 2a:08:18:9f:7a:8e
Drives:    HDD Total Size: 250.1GB (3.6% used) ID-1: /dev/sda model: Hitachi_HTS54252 size: 250.1GB
Partition: ID-1: / size: 20G used: 4.6G (25%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 4.25GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 52.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 130 Uptime: 8 min Memory: 290.2/3503.7MB Client: Shell (bash) inxi: 2.3.1

As you can see my audio chip is slightly different from yours, I wonder if alsa is set up correctly? Have you checked with alsamixer to check nothing is muted? or anything else that might give a clue to the problem?
When you said "Pulsemixer shows output as DUMMY as only selection" was that from pavucontrol? and did it show "DUMMY" where it would normally show speakers or headphones?


yes pavucontrol pops up from the panel control icon.
pavucontrol and alsamixer have been checked.
alsamixer finds the HDA chip
but pulse does not link to it.

Should I file a debian bug?
XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness


You could submit a bug report, I would only be guessing that it should be filed with debian, but if it were me I would first try one of two things...

1. perform a fresh install and perform all system updates before installing additional software. Test if everything works.

2. perform a fresh DEBIAN install with same desktop, perform all updates before installing additional software. Test if everything works.

I always multiboot my systems and currently have 7 different Os's on my laptop mainly used for testing and troubleshooting, if I cannot reproduce an error on the exact same hardware then I do not report it as bug to debian, because I cannot say for sure if it is a bug or something I might have changed.
I'm not suggesting you install a heap of other Os's though, but if a fresh install of sparky doesn't reproduce the error then you can either use that and wipe the old installation, or if it does reproduce the error then you would have a definite bug. The only thing to then discover would be if it is a debian bug or a sparky bug...


there is no way I can get DEBIAN with my slow internet speed here.
I've migrated most of work to xubuntu 16.04 and will be monitoring it for issues.
Sparky continues  to report several Call Traces & i'll keep updating it. hoping for a fix
I did file a debian bug report Bug#844328:
XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness


I did a clean install of Home Edition kernel 4.2 onto another partition [2]
then did a full safe upgrade to 4.8
that install is now hard locking on bootup , it displays Call Trace errors then hangs, no TTY

I will post this critical bug in more detail in another topic
XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness


thank you for the help.
I used Sparky for awhile as this laptop's main distro but the upgrades broke sound.
I've removed Sparky from this laptop because I needed storage space on the SSD.
If someone else experiences this sound issue, I hope there will be a solution.

XMPP:  Twitter: in limbo   [email][/email]
Secular Humanist, progressive, antifa, goodness without godness

View the most recent posts on the forum