Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

SPARKY LINUX 4.3 GAMEOVER 32-BIT - Red X's & Missing Icons & Black Screen &

Started by NEWSPARKMAN, September 02, 2016, 09:15:24 AM

Previous topic - Next topic


I am not sure if it is related to a known issue, but,...

I did "System Update", (Icon on bottom left of default desktop screen), yesterday, on SPARKY LINUX 4.3 GAMEOVER 32-BIT, and now have no icons and menus working, (just red X symbols where icons would be), and black desktop screen.

I am no expert on Linux/Debian, but, I installed SPARKY LINUX 4.3 GAMEOVER 32BIT after testing my system with a verified, Live CD of same version I installed, with 0 issues, then, installed with 0 issues for like 3 days, then, set up included GUFW, Clamav, and then did apt get update, apt get upgrade, and also clicked on "System Update" on the desktop bar bottom left icon, with successful updates, no issues, during update.  Everything seemed fine.

Then, I went to Synaptic and removed a few pre - installed games I will not use.  Verified each was a game by carefully watching description when selecting, after testing actual game from default menu.

I then downloaded a large Rar file to downloads, but, didn't extract it yet, logged off, and shutdown.  Next day, upon entering desktop, everything is broken looking, with red X s all over.

I scanned download, and system files but no virus, so, download can't be to blame, as it wasn't even extracted, nor, installed.

Any suggestions as to how to fix this?

My main OS Ubuntu Studio 16, (dual boot), works fine still.  (2 week old install).  So, at least it isn't some major HDD crashing issue, or virus / malware / trojan issue, (at least I can tell), as both OS installs are on same HDD, different primary partitions.

Things felt stable before all this happened, other than a few times I had to re type my password (half the time, was not every time, though), when logging into the desktop, and I was typing super slow, and never usually have issues with password login situations.  So, but, other than that, all was good, until now.  :-\


It looks like one of two possible issues:
1. Upgrade went wrong and some packages been not upgraded and broken the system.2
2. Upgrade went well, but new versions on graphical drivers broken something.

Solution: there is Sparky 4.4 GameOver out so reinstall the system using the latest iso.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Yes, I would agree, those are possibly what happened.

Also, when did SPARKYLIN 4.4 GAMEOVER release?  Today?  What is difference from 4.3 GAMEOVER to 4.4?  Any major bug fixes?  Are all new updates included now?

What if newEST updates are what broke my system?  I am normally rock solid running most any OS's on my custom X58 system.

I mainly want to install, and play most stable WINE capable OS, and I chose SPARKYLINUX GAMEOVER 32BIT since it had WINE pre-installed, and configured, and I was told directly from WINEHQ, AND WINEWIKI to use 32BIT not 64BIT OS for best WINE situation, unless doing an advanced custom install "BI-ARCH / MULTI-ARCH HYBRID 64BIT & 32BIT COMBO" type set up, of which I do not feel comfortable setting up, after reading the guide, and steps from WINEHQ.  Is that wrong?  Am I confused?

I normally have always run 64BIT OS's ...since even XP PRO 64BIT back in 2004 I think it was, and now using 64BIT UBUNTU instead, so, this was 1st 32BIT OS in over 12 years, and many systems.


Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


I just posted this same problem on a different thread. I forgot about the icons having little red Xs. If I reinstall, then I'd lose all my installed programs and data, right? Is there a way to fix what's wrong through the command line (as that's all i can boot into right now) without completely reinstalling?

Update: Finally got it working by rebooting, using Advanced to login from grub, doing a apt-get update, apt-get dist-upgrade, apt-get autoremove and rebooting. I did it twice because I got an error about not being able to write to a file. I think it was a i386 lib (don't know how to get a screenshot so I don't remember what file it was). But the second time it worked! So, this is solved for me for now.

Thank you for the information. :)

View the most recent posts on the forum