Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Steam

Started by kjaras, August 21, 2016, 09:40:30 PM

Previous topic - Next topic

kjaras

just installed sparky and trying linux for the first time and when i click the steam icon nothing happens and when i go to the steam web site and try to install from there i get this from debian installer : error No longer provides steam launcher.

Could not look up the parent vendor of SparkyLinux at /usr/share/lintian/commands/lintian line 1551.

Lintian finished with exit status 2

so how do i get steam ?  :D

also im running the gaming distro of sparky

pavroo

What Sparky version you have installed - 32 or 64 bit?
Have you fully upgraded the system?

Run the command in a terminal emulator:
steam
and show the full output.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

kjaras

steam
Running Steam on sparky 4 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
^C

and yes i have fully upgraded the system or atleast i clicked the upgrade button and let the stuff happen :)

pavroo

It should help:
http://askubuntu.com/questions/541343/problems-with-libgl-fbconfigs-swrast-through-each-update
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

kjaras

i dont think that did anything and im not good with the consol thing :( its first time im running linux and im not sure how to to the commands properly or where to enter them i have like 3 consols to choose between LX, UX and X

i tried to follow this link too http://askubuntu.com/questions/451221/ubuntu-14-04-install-nvidia-driver/451248#451248 

and im nor sure how this works i tried but after the sudo nano /etc/modprobe.d/blacklist-nouveau.conf command i got stuck 

    sudo apt-get remove nvidia* && sudo apt-get autoremove

After you finish with this one, you should also blacklist the nouveau driver by editing this file with either:

    gksudo gedit /etc/modprobe.d/blacklist-nouveau.conf

or

    sudo nano /etc/modprobe.d/blacklist-nouveau.conf

...and add these lines at the end:

    blacklist nouveau
    blacklist lbm-nouveau
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off

kjaras

its working now i went into the synaptic package handler and selected nvidia driver and installed it that solved the problem :)

Goofy

I can confirm kjaras solution! Now Steam is running also on my computer, thank you kjaras!    :)

For Newbies like me, I want give more details:
If you have found the entry "nvidia-driver" with label "nvidia-megapackage" in that giant list of the synaptic package handler and you have started the process, the programm startet a 'big' download over 30mb and execute the installation; -Don't disturb it.
Then reboot the computer.

In my case there was an additional problem: The Steam-Client did not want to start as root (it identify me as root). Perhaps because of the automatically installation of Sparky, which allows me as user to do administrator things...   :o
I could handle that with the command 'sudo -u goofy steam' (in the LXTerminal). goofy is my username and must individually changed.

And then the Steam-Client is running. It begans with download of 270mb! for an update. After this update the Steam-Client is running by clicking the icon, without any problems.

What I have misunderstood apparently is, that the programm updates with APTus doesn't include the Steam-Client. And the pre-installed Steam-Client was one important reason for me to select the Sparky-Linux...  :-\

Now, it works and its great; But I think that Story is not the best advertisement for Sparky. The post from kjaras is from August 2016, and the problem is still the same...

View the most recent posts on the forum