Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

After apt-get dist-upgrade mate apps using gtk fail

Started by kulturedyobbo, June 04, 2016, 02:23:22 AM

Previous topic - Next topic


Hi there

When I updated my system yesterday with "apt-get dist-upgrade" (03rd June 2016), I found that my mate apps such as pluma and eye of mate no longer worked. When I executed them from the command line, I got this message:

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported

My OS is Sparky Linux, OS version 4, OS Code Name: Tyche, Kernel: 4.5.0-2-amd64.

My version of Pluma is 1.14.0-1 and eye of mate 3.20.2-1. I have tried uninstalling and reinstalling all of mate with no luck.



Problem with MATE 1.14.0 after upgrade here too.
Pluma, caja, eye of mate works fine after I included sid repositories, update and run:

sudo apt-get install --reinstall mate-desktop-environment
sudo apt-get install --reinstall mate-desktop-environment-extras

This also upgrades Marco to unstable version.
Some panel applets like mate-sensors and mate-system-monitor dissapeared so I upgrade them too to unstable (1.14) version.
Now everything seems to work fine except those two applets.
As they are pinned on a second autohidden left-oriented panel, sometimes when I mouseover/mouseout that panel, i have a "quit unexpectedly" error and they dissapear but they appear again after I choose reload.
Any suggestions?


Wait.  Check out the irc for mate.  Wait.  Huge changes in GTK3 land is documented  in many places.  It can take a couple days for things to settle down in unstable and testing.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


I found the problem. It was a sync problem with my mirror. I was using the mirror "" in my city which updated pluma to version 1.14 but still left mate-desktop at version 1.12. Pluma 1.14 needs mate-desktop 1.14. When I changed my  mirror to "", and updated, the problem was solved. The thing is, I also received a dozen or so more package updates, which implies more than just these mate apps are out of sync.

Another thing, I also tried the mirror "", but just like "", it to was out of sync. It seems that at the moment, only mirrors which contain "" are properly in sync, and I have since found out that Debian itself only has control of these mirrors with "".


MATE version 1.12.1 (the version i had before upgrade) uses GTK3 as well. So, those apps keeps running after upgrade to 1.14. You may had a version older than 1.12.1 using GTK 2.
Now I use the unstable version of MATE with some issues with some applets. I'll be waiting for them to get solved or I'll downgrade my MATE back to 1.12.1.

View the most recent posts on the forum