Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

sparky-aptus-upgrade thinks it is a Live system!

Started by eightbit, May 06, 2016, 03:17:51 AM

Previous topic - Next topic


I think it has something to do with the live backup I made using Systemback of my custom Sparky. But it is not live anymore. It has been installed for quite some time. Normal sudo apt-get upgrade and dist-upgrade work fine. But when I run the Sparky updater I get "It's a Live System! Install Sparky on a hard drive and then upgrade it. Exiting now..."

Even tho it is installed, the updater thinks it is a live system. Any idea how this can be corrected?


I don't know the Systemback and don't know how is it work.
Looks like (I guess) it added 'live' user to the backup iso so the user still exist after installation on a hard drive.
Sparky Backup Sys doesn't add it, just create (on the fly) the live user using live scripts.

To find out what is going on, show me:
cat /etc/passwd | grep 1000
cat /etc/passwd | grep 1001
cat /etc/passwd | grep 1002
cat /etc/passwd | grep live
cat /etc/passwd | grep Live
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I think you may be on to something. I will certainly reply with the outputs in this post when I get home from work later tonight. Thank you for your assistance with this!


Ok, ran all of the cat commands and only one gave me an output:

bruce@eightbit:~$ cat /etc/passwd | grep 1000
bruce@eightbit:~$ cat /etc/passwd | grep 1001
bruce@eightbit:~$ cat /etc/passwd | grep 1002
bruce@eightbit:~$ cat /etc/passwd | grep live
bruce@eightbit:~$ cat /etc/passwd | grep Live


The live installer creates new user using the first available ID: 1000
Yours 1000 is empty so it says it wasn't during installation.

The second thing is about detecting the live user in the sparky-aptus-upgrade tool.
I changed it so upgrade the tool (up to version 0.2.1):
sudo apt-get update
sudo apt-get install sparky-aptus-upgrade

Then run the Upgrade System tool normaly and let me know did it help.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


It works now! Thank you so much for the help!


Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Now sparky-backup-sys does the same thing (I am testing it instead of systemback). I am assuming it is the same issue...

ANd sparky-firstrun does nothing when launched. I wonder if this is also this user issue?


I am not sure what is wrong, but looks like the live installer created a new user with ID different than 1000, because the live user still has ID 1000.
Show me the installation log:
and the sparkybackup log:

The sparky-firstrun has been updated to version 0.1.10 to fix it too.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


None of those logs exist. It looks like systemback created the installer differently.


Anyway, the sparky-firstrun is upgraded too so install the latest version to be working well in the new iso image.

The 'live-installer.log' and 'sparkylinux-installer.log' will be placed in the new installed system.
If you used sparky-backup sys to create an iso image, the log will be placed in the present system.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


I see. Thank you for all of your help once again!

View the most recent posts on the forum