Development > Remastering

System restore ISO file ?

(1/3) > >>

jenom:
I can see from packages list that there is
--sparky-backup
--sparky-core
--sparky-sys

Does any of them create an ISO file as a snapshot of the current system, and this ISO than can be burned to USB memory/CD to restore system ?

Thanks!

pavroo:
Check the packages description to find out.

Anyway:
- sparky-backup-core makes the snapshot of your existing installation and creates an iso image - it works in text mode only
- sparky-backup-sys provides the yad based gui for sparky-backup-core
- sparky-backup-apps makes backup of your some application only, such as web browser settings, mails and settings of e-mail client, etc.

jenom:
thank you for your reply, here is my experience:

1) installed backup-core and backup-sys
2) run backup

A)
 get a message during, "live-installer is NOT installed so copying the old installer desktop launcher"

B)
also get a message near the end, did not have time to write it down, it was about EFI something was not found , and something about hybrid image

C)
looked at the saved backup log file for these two messages----they were not there !

E)
burned the created ISO to an USB stick with rufus, it booted fine , login did not have my username, it had only "live session user",  with password "live" went to desktop

F)
I have Sparky Advanced Installer (sparkylinux-installer.desktop) on my desktop and menu, looks like a "live-installer" is missing !

Afterall, It did a good job saving all pkg-es and setups, but it did not save my username/account.

Still somewhat concerned about messages A ,B and F.......maybe something can be done about to fix them?

Thanks!

jenom:
UPDATE:

Found "live-install" package after enabling more repos in synaptic repositories.
However, when tried to install it, got this message:

--------UNRESOLVABLE DEPENDENCIES---------

live-installer:
 Depends: python-webkit  but it is not installable
 Depends: python-parted but it is not going to be installed
 Depends: gparted but it is not going to be installed
 Depends: python-geoip but it is not going to be installed
 Depends: python-opencv but it is not going to be installed
 Depends: python-qt4 but it is not going to be installed
 Depends: streamer but it is not going to be installed
 Depends: gdisk but it is not going to be installed
 Depends: isoquery but it is not going to be installed

-webkit- and -opencv was very hard to find.....enabled ALL repos and suddenly they were available>>>>now I have "live-install" installed


UPDATE:

did some reading about EFI/UEFI and BIOS, I still have a BIOS, so I do not need to be concerned about this

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Going to do another SPARKY-BACKUP , because now I have "live-install"

pavroo:
A: The live-installer is an option. If you will not install it, you still have the old (advanced) installer available to use.

B: The GUI -> Sparky Backup System provides an info about what should be done (5 *efi.grub debs to be added) to provide efi support for the both 'live-installer" and 'sparky-advanced-installer' on target machines with UEFI motherboard. If you have BIOS, the option can be ignored.

E. Probably you have used 'dist' mode which creates new iso image with 'live' user, which can be used as a new installation media for anybody.
There is 'backup' mode to create a backup of your installation with your existing user and settings.
Simply run (in a terminal):

--- Code: ---sparkybackup
--- End code ---
to find out more.
The GUI has to be improved to evoid misunderstanding with cli options 'backup' and 'dist'.

F. The 'sparky-backup-core' provides Sparky Advanced Instaler in a case of missing Live Installer or any problem with the Live Installer.

Navigation

[0] Message Index

[#] Next page

Go to full version