Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Screen tearing in Kodi 6.0.3 Jarvis [SOLVED]

Started by AndyInMokum, March 05, 2016, 03:41:49 AM

Previous topic - Next topic


Hi everyone, how's it going.  I've run into a small issue while running the new Kodi version, Jarvis.  The installation is from the official testing repos.  The installation went without an issue.  Kodi opened up and updated.  The issue I'm having is when I play a video, I get screen tearing at the bottom.  The best way to describe it, is it looks like a green bar graph flickering at the bottom of the screen.  My computer certainly has the graphics capability necessary to run Kodi.  I dual boot it with Peppermint Six.  This is based on Ubuntu 14.02.2 LTS with the 3.16.0-60-generic x86_64 kernel.  The same version of Kodi is installed on it and the video runs perfectly.  It's got me really confused.  Any ideas would be much appreciated.  Below is my inxi -F output:andy@sparkylinux-latitude:~$ inxi -F
System:    Host: sparkylinux-latitude Kernel: 4.2.0-1-amd64 x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Sparky 4 Tyche
Machine:   System: Dell product: Latitude E6410 v: 0001
           Mobo: Dell model: 0667CC v: A03 Bios: Dell v: A07 date: 02/15/2011
CPU:       Dual core Intel Core i5 M 560 (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2667 MHz 1: 1199 MHz 2: 1333 MHz 3: 1466 MHz
           4: 1999 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.18.1 driver: intel
           Resolution: 1280x800@60.00hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile
           GLX Version: 2.1 Mesa 11.1.2
Audio:     Card Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.2.0-1-amd64
Network:   Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e
           IF: eth0 state: down mac: 5c:26:0a:5b:95:ef
           Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi
           IF: wlan0 state: up mac: 18:3d:a2:67:d6:f0
Drives:    HDD Total Size: 1120.2GB (10.7% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB
           ID-2: /dev/sdb model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 20G used: 7.6G (41%) fs: ext4 dev: /dev/sda9
           ID-2: /home size: 14G used: 3.6G (27%) fs: ext4 dev: /dev/sda10
           ID-3: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
Sensors:   System Temperatures: cpu: 60.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 194 Uptime: 19 min Memory: 958.5/7914.1MB
           Client: Shell (bash) inxi: 2.2.28
Backup, Backup, Backup.  If you're missing any of these, you ain't backed up.


I looked up Kodi, it is a very specific cohesive suite. Are you installing via standard debian testing repositories or via the Kodi repository ppa. Do not use the jessiebackports to install - you are in testing.   Although it is not always the case, anytime I see launchpad I think ubuntu. The gap between a Debian machine with Ubuntu .debs is getting larger and larger. Things may or may not work. On the computer I am on now "Version: 16.0+dfsg1-1" is offered up via a simulated apt-get install in unstable. 

Off of their web page Kodi cautions against unsupported addons and repositories, but you are probably not doing that. 

One very quick test to see if it is Kodi or your install would be to apt-get install mpv.  It is very light weight install if you have ffmpeg installed.  You could see if tearing occurs when you use mpv to view a media file.   

Thanks for using inxi.  peace out.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Yeah, it's a standard install from the Testing repos.  Certainly no ppa involvement, this is Debian ;D.  No backporting to Jessie either.  I've tried playing videos in both MPV and VLC.  Videos play perfectly in both packages.  It must be Kodi itself.  Their Jarvis release is very new.  There are probably a few bugs to iron out.  Hopefully after the dust has settled, they'll pump out some fixes.  I'll keep this thread open for the moment.  Others may find it useful, if they're experiencing the same weirdness.  Thanks for the advice  ;).
Backup, Backup, Backup.  If you're missing any of these, you ain't backed up.


I've managed to resolved the issue.  The green pixelation was being caused by Kodi's built in hardware acceleration.  If anyone is having similar issues, the setting in Kodi can be found by navigating to: System > Settings > Video > Acceleration.  On my machine, (see first post for full specifications), VDPAU, (Video Decode and Presentation API for Unix) and VAAPI, (Video Acceleration API) hardware acceleration can't be run together.  VAAPI can't be run at all.  For video playback to remain stable, either all hardware acceleration must be turned off or, only have VDPAU acceleration turned on.  I suspect the combinations may vary from computer to computer, so some trial and error experimentation may be necessary.  I hope this provides help for future visitors with a similar issue.  On that note, I'll call this mystery solved  ;).
Backup, Backup, Backup.  If you're missing any of these, you ain't backed up.

View the most recent posts on the forum