Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Sparky 4.2 i586 on HP Pavilion 2x Detachable

Started by alphilmac, February 18, 2016, 08:03:06 PM

Previous topic - Next topic



In November 2015 I've got this HP Pavilion 2x Detachable running Win 8.1 later on upgraded to Win 10. I searched from the beginning to find a Linux for it, however, this is a peculiar gadget having 32bi UEFI and none of the typical distros would boot. I gave up and continued using it with Win 10 (for first time since November 1998 I was using Windows) until today it entered an infinite loop in booting between blue screens of death (Yes, they are back!) showing UNEXPECTED_KERNEL_MODE_TRAP. Searching for help on the latter, I found Sparky Linux! It boots like  a charm from a usb stick! Thank you guys! However, there are some driver issues. I do not have network and I do not have neither sound or blue tooth. I would appreciate help or advise to overcome the difficulties. Thank you in advance. Here are the crucial (red) lines from the demsg:

ioremap error for 0x7b456000-0x7b45700, requested 0x2, got 0x0
dmi: Firmware restration failed

Failed to fnd cpu0 device node
Unable to detect cache hierarchy from DT for CPU 0

i8042: PNP: No PS/2 controller found. Probing ports directly
i8042: No controller found

ioremap error for 0x7b456000-0x7b457000, requested 0x2, got 0x0
ioremap error for 0x7b25a000-0x7b25b000, requested 0x2, got 0x0
esrt: ioremap(0x7b25a410, 56) failed.

sst-acpi 80860F28:00: firmware: failed to load intel/fw_sst_0f28.bin-i2s_master (-2)
sst-acpi 80860F28:00: Direct firmware load for intel/fw_sst_0f28.bin-48kHz_i2s_master failed with error -2
sst-acpi 80860F28:00: Cannot load firmware intel/fw_sst_0f28.bin-48kHz_i2s_master

dw_dmac INTL9C60:00: Missing DT data
dw_dmac INTL9C60:00: DesignWare DMA Controller, 8 channels
dw_dmac INTL9C60:01: Missing DT data
dw_dmac INTL9C60:01: DesignWare DMA Controller, 8 channels

kvm: disabled by bios

byt-rt5640 byt-rt5640: ASoC: CPU DAI baytrail-pcm-audio not registered

byt-rt5640 byt-rt5640: ASoC: CPU DAI baytrail-pcm-audio not registered


Which sparky?   Less is good.  With things like this, ethernet and the command line is your friend. 

Yes, sounds like a Baytrail, a very peculiar gadget.  Several forums I know  just say, "sorry, can't help."  Myself, I have never dealt with uefi.  You might also try searching at BunsenLabs forum,  they are open to  interesting topics and are nice.  I heard of a Fedora spin off that was working on this, but that is all I know. 

In the end, how much time do you want to invest in an uphill task.  As much as I hate windoze, with a linux system rescue disk and your knowledge and some search engine work you can probably get your Win10 back. 

Hopefully I am too pessimistic and others will chime in with some helpful news.    Peace out
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


I have tried Sparky 4.2 i586 kde. But this does not seem to be a Sparky issue per se, rather it is a Debian issue (if you google on some of the errors). However, the main problem is the network as this gadget lacks ethernet connection and it can only be connected using wifi.Unfortunately the latter is based on Realtek RTL8723BS, and realtek has always been problematic.

I've got  the gadget back to win 10 but the truth is that I've never wished for it and it also never worked well. Since the upgrade from win 8.1, the camera is not functioning (this seems to be a very typical problem for win 10) and the blue tooth is enigmatic and random (and HP / MS advises are the typical ones: keep uninstall and re-install the drivers) . So now, when I've discovered that Sparky can run on it (with almost the same issues) I will do everything in my power to get it run smoothly. Therefore any help and suggestions will be greatly appreciated.


Well then, proceed onwards.  The Kde spin is probably the spin with the most
"heavy" development with the transition of KF5 and plasma 5 (the Qt part is settled down). It also has heavier demands on the cpu. The Xfce spin might be the lightest for transitions and demands on the cpu. 

But it only takes one brave soul to crack the Realtek nut and post a solution. 

Glad you got past the install.  I would say, hey try connman for setting up the networking, but the packaging has stalled under Debian. I get my connman via Siduction repository (1.31-6 versus 1.21-1.2 for Sid) on my other lxqt machine.  Nasty bug presently for connman in testing (and unstable).   Connman  (and ofono for phones) have strong ties to intel developers, but they are not very chatty.   It is a bit of a learning curve for connmanctl, but well thought out for command line usage.   

Peace out, 

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum