Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

no display after upgrading yesterday

Started by piker, February 10, 2016, 01:18:55 AM

Previous topic - Next topic


I am using Lxqt Sparky and did my usual monthly upgrade yesterday. I have been successfully using the Nvidia Propriety Driver (for 4 months) installed via Device Driver Manager. Yestertday during upgrading I was asked whether an Nvidia Driver, which it said was incompatable with my system, should be installed. This question was asked about 5-6 times at which I answered NO. I rebooted afterwards and was greeted with only a blinking cursor. Upon examination it seems that Lightdm is failing. I thought it may be because of a newer Nvidia driver so I uninstalled all Nvidia stuff but still no display.
Could someone please advise me how to get a display up again? Thanks.


I did a complete purge of anything nvidia related and have now managed to get to at least get to the Sparky splashscreen, but then it goes back to the command line for log in. After logging in and running "startlxqt" it fails. I also tried removing lightdm and replacing it with lxdm - with no success. Isit possible that this problem is due to an incompatability with xorg's recent version??
Im really stuck here and could use some help to get a display back...


short answer - probably xorg 1.18,3417.0.html    "My guess is that non-free drivers will take longer to transition. "

In these situations, your first step is to get into tty1  via "Ctl-Alt-F1"  log in as root and gather data from there.   It is possible that you might have to escalate via going to rescue via your grub options or even chroot in via a "live-cd"   but your first step is to try tty1.

From some people who dealt with xorg 1.18 in unstable

Please post output of "inxi" and inxi -G"

You probably want to examine "journalctl -b -0    and for less output journalctl -b -0 | grep <<the name of your video driver as found via inxi -G>>

Any talk about this on #debian-next on OFTC or on debian forum? 

My guarded opinion is that lightdm is not at all part of the problem.  lxdm is a huge regression.  The most probable solution is to remove the non-free nvidia binary and go with the open source debian version.  It sounds like you have done that.  That can be confirmed via the inxi -G 

If you are doing sparky lxqt it is wise to follow the #lxde irc on freenode  The #lxde  irc onOFTC is geared towards LXDE
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


thanks paxmark1 for the great advice and i'm almost certain it was xorg that caused it. I did get things working again last night by purging all nvidia* items, removing "nvidia" as the device driver in xorg.conf (obviously important) and replacing it with "nouveau" there. Once into Sparky I then used the DDM to install the proprietary Nvidia driver and voila! It took a couple of days but i'm back in business without a reinstall! Hope this helps someone else....cheers.

# I should add here that I have a Dell Vostro 3500 laptop which has a particularly troublesome graphics card which refuses to suspend using Nouveau - hence the need for the proprietary Nvidia driver.

View the most recent posts on the forum