Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Hello! I love Sparky!

Started by eightbit, November 09, 2015, 04:11:12 AM

Previous topic - Next topic


Just a hello from someone who absolutely LOVES this distro! I have been distro hopping here and there over the years and have tried just about everything you can imagine. I always ended up going back to an Ubuntu derivative. I wanted Debian testing, but in a distro that had some basic things already set up. I heard about Sparky and was happy to see a MATE version available. After testing the live USB I decided to install it and have not looked back. Everything just works! Even the lights on my Xbox 360 controller :)

I was able to build Retroarch from source ( without issue which was great (I couldn't build this in another Debian based distro I had tried) and I am in gaming heaven :) As a matter of fact, here are the steps you need to take to build it successfully. It would be great to see it included in a Game Over edition one day (since I have not encountered a single distro that includes Retroarch to date!):

sudo apt-get install debhelper dh-exec libasound2-dev libavcodec-dev libavdevice-dev libavformat-dev libavutil-dev libc6-dev libdrm-dev libegl1-mesa-dev libfreetype6-dev libgbm-dev libjack-jackd2-dev libopenal-dev libpulse-dev libsdl2-dev libswscale-dev libudev-dev libusb-1.0-0-dev libv4l-dev libxinerama-dev libxml2-dev libxv-dev libxxf86vm-dev pkg-config python3-dev x11proto-xext-dev zlib1g-dev devscripts git nvidia-cg-toolkit

git clone git://

cd libretro-super




mkdir -p ~/ra/cores

cd retroarch

make DESTDIR=~/ra install

cd ..

./ ~/ra/cores

Last few lines install Retroarch and cores in the "ra" folder under home. Just run the retroarch executable and set up the paths (point to cores, roms, etc) and you have an emulator that can plays dozens of handhelds, consoles and arcade machines. Hope it helps someone as documentation for Debian building is sparse to say the least. And please do not change what you are doing with Sparky Linux! Everything is just right!


You guide seemed to work perfectly until my terminal stopped at (on fetch)...

libretro_fetch:No URL set to fetch REminiscence via git

If I try to ./ next it errors at...

command.c: In function 'command_event':
command.c:2839:13: warning: implicit declaration of function 'discord_init' [-Wimplicit-function-declaration]
command.c:2847:10: warning: implicit declaration of function 'discord_shutdown' [-Wimplicit-function-declaration]
command.c:2855:13: error: unknown type name 'discord_userdata_t'
             discord_userdata_t *userdata = (discord_userdata_t*)data;
command.c:2855:45: error: 'discord_userdata_t' undeclared (first use in this function)
             discord_userdata_t *userdata = (discord_userdata_t*)data;
command.c:2855:45: note: each undeclared identifier is reported only once for each function it appears in
command.c:2855:64: error: expected expression before ')' token
             discord_userdata_t *userdata = (discord_userdata_t*)data;
command.c:2856:13: warning: implicit declaration of function 'discord_update' [-Wimplicit-function-declaration]
command.c:2856:36: error: request for member 'status' in something not a structure or union
Makefile:191: recipe for target 'obj-unix/release/command.o' failed
make: *** [obj-unix/release/command.o] Error 1
make: *** Waiting for unfinished jobs....
Failed to build RetroArch

Redoing the fetch stops at the same place. Any ideas?


The 'retroarch' package is in Debian's repo, so no need to build manually.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


View the most recent posts on the forum