Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

No Desktop every 2nd boot

Started by msbln, August 04, 2015, 03:32:14 PM

Previous topic - Next topic


Hello, I installed Sparky4Openbox and after that mate-desktop-environment.

Every second boot there is only a black screen with a non-blincking prompt in the upper left.
(Mate did not introduce that problem, it was already present with Openbox)

I don't know where to start to fix it.

Any ideas?



Ok, I tried it on another computer, a Thinkpad X41 Tablet.

The behaviour could not be reproduced.
(But it was the 32-bit version)

On the "faulty" machine (64-bit) I can circumvent the problem by using
booting with Recovery Mode. This will boot always correctly,
BUT it seems
some previous changes, i.e. in the conky config file, are overriden by default values.
Therefore this might be not a real fix.


Well, the mysterious boot behaviour seems to be gone for now.

I don't understand, all I did was
uncomment the "quiet splash" in Grub.

Maybe something with Grub that fixed itself after an update-grub.

Btw, how can activate boot logging?


I can launch Sparky only if I choose Recovery option in the Grub menu.

Otherwise now it ALWAYS gets stuck.

Other Linux systems on the same computer start without problems.

What's the difference between normal and recovery option and
what's Sparky doing differently while booting than other Linux systems?


Ok, I uploaded all boot loader information possible:

What the hell is wrong with sda7 ?

after re-installing GRUB I can normal-boot Sparky (on sda7) without problems for ONE time only.
After that it always gets stuck, STRG+ALT+F1... shows no reaction.


i have a similar issue:

when i turn pc office on, the first time it would get stuck soon after the grub screen
the only sure way to make it boot properly is to turn it off (by pressing the power button for 4 seconds) and turn it on again, no matter what kernel i choose


Hi carlo,

have you tried choosing Recovery Mode in GRUB
and pressing Ctrl+D after the boot lines stop?


I' going to test it tomorrow 


i've tried, but fruitlessly
even "lock leds" are stuck; ctrl-alt-can, ctr-alt-f1, etc don't have any effect


Hi carlo,

you are experiencing the same problem I had at the beginning.
Good to know I'm not alone.

You might try the following:

- install the bootlogd package
- see the output in /var/log/boot.log

1) after successful boot
2) after unsuccessful boot (for example via live-cd)

I have tried the above BUT
my boot.log was always empty!
Maybe you have more luck.


Thank you msbin
ill try to do it this evening

I've taken a screen shot of one of the booking failures which give some debug meaage this morning
but since I'm from mobile cannot upload it right now

I'll keep you updated


i'm installing the two programs,
however this happens every now and then


Quote from: msbln on October 02, 2015, 01:51:12 PM
I have tried the above BUT
my boot.log was always empty!
Maybe you have more luck.

Mine too!
when i have the underscroll *or whoever( blinking i guess grub just ... fails..


Hi carlo,

thanks for the screenshot, but the lines are way over my head.
Maybe a pro can help to interpret them.

Quote from: carlo on October 02, 2015, 06:31:23 PM
Mine too!
(...) i guess grub just ... fails..

If GRUB fails, why does it NOT fail
after cold restart - in your case
after choosing GRUB's Recovery mode  - in my case,
I don't understand.

AND the empty boot.log  >:(

how did you upload the screenshot?
I could deliver a screenshot from my disk layout,
but I cannot see how to attach a pic to a post.


Quotebut the lines are way over my head.
it's incredibly tooo much difficult for me :'( :'( :'( :'(

QuoteIf GRUB fails, why does it NOT fail
after cold restart - in your case
after choosing GRUB's Recovery mode  - in my case,
I don't understand.

odd indeed..
but i guess i have issues with my mobo (a loosy -to be gentle- asrock):
when i used ubuntu mint on that pc i had far more issues in booting, and sometimes it just froze while using,
so i had a memtest, tried and tried the two ram blocks again ad again, and it turned out that if i use only one, no matter what slot i use i would never have any error, but if i use both of the ram thingies i have errors
Now besides booting issues i notice i have some random major failure when i leave some radio player on and the screensaver starts: i would have to kill xorg or reboot so that pc properly works again...

did you try a memtest?

Quotehow did you upload the screenshot?
i manage a website, so i have put the image online, and added the link to it between the "img" tags

View the most recent posts on the forum