Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

grub fails to update

Started by carlo, July 07, 2015, 06:11:15 PM

Previous topic - Next topic

carlo

hi all
i've noticed it's some kernel versions that grub isn't upgrading properly......
now i've removed grub customizer and tried to purge and resintall grub, but i always get the very same message:


......
Trovata immagine initrd: /boot/initrd.img-3.16.0-4-amd64
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
Trovato Linux Mint 17.1 Rebecca (17.1) su /dev/sda5
errore: syntax error.
errore: Incorrect command.
errore: syntax error.
errore: Incorrect command.
errore: syntax error.
Errore di sintassi alla riga 189
Errori di sintassi sono stati rilevati nel file di configurazione
di GRUB generato. Assicurarsi che non vi siano errori in
/etc/default/grub e /etc/grub.d/* o segnalare un bug allegando
il file /boot/grub/grub.cfg.new.


actually the file it tells me to attach is here: http://www.federproprietaabruzzo.it/Carlo/grub.cfg.new:

pavroo

I don't know what installing and removing grub-customizer changed in grub config files, but it could.
I suggest reinstalling all installed grub files (should be 4 packs) and update grub manually after to check is still somenthing wrong.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

carlo

i guess i've already done what you suggested, but the outcome would always be the same: check all of the /grub.d/ config files or report for bug

what if i try to install grub 1?

pavroo

I don't think it's a good idea.

Try: edit as root the file: /etc/default/grub and past inside, on the end of the file:
GRUB_DISABLE_SUBMENU=y
Then:
sudo update-grub

You have 8 Liquorix and 2 Debians kernels installed.
Do you need all of them?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

carlo

Quote
Try: edit as root the file: /etc/default/grub and past inside, on the end of the file:
Code: [Select]

GRUB_DISABLE_SUBMENU=y

Then:
Code: [Select]

sudo update-grub


alas it did the very same thing...


QuoteYou have 8 Liquorix and 2 Debians kernels installed.
Do you need all of them?
isn't it "the more the better"?

carlo

i've made an apt-get autoremove
it deleted some liquorix and maybe something from nvidia from what i could tell, then it sort of made update-grub many times, and i've noticed that this kind of messages
Errore di sintassi alla riga 567
appeared:
it says on line 567 there's a syntax error:
i've checked through /etc/defaults/grub and /etc/grub.d/* but no single file has so many lines
the only file to have enough lines is the /boot/grub/grub.cfg.new, which i'm going to upload again, just in case it change: http://www.federproprietaabruzzo.it/Carlo/grub.cfg.new2

pavroo

The line shows that it's about function gfxmode.

Looks like the file  /boot/grub/grub.cfg.new has been made by grub-customizer before.
Can you move the file (as root) out of the /boot/grub directory and update grub again?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

carlo

i've move grub.cfg* to /tmp but the update grub command gives the very same output....

what is updaate-grub2 about?

pavroo

update-grub2 is a symlink to update-grub only so they run the same command
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

carlo

Actually grub totally failed to boot
Not sure whether to try to recover the files ive moved ir try a live grub install...

pavroo

Quotei've move grub.cfg*
have you moved all grub.cfg* files out?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

carlo


pavroo

That's why it's not useable now.
I said to move /boot/grub/grub.cfg.new file only.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

carlo

hope i can find them when i'm back in office.....



just in case:
if i format is there any way to tell debian "pliiiiis install all the packages i had before i made anything wrong" in a short easy way?

carlo

i took the third path:

i've booted from sparky xfce, launched grub-repair:
it made me purge everything, then it reinstalled grub
with the latest debian and liquorix kernel besides linux mint
and boot works now
thank you

View the most recent posts on the forum