Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Ethernet not auto "activating" BCM4401-B0 [SOLVED]

Started by ElQuia, July 20, 2015, 05:31:18 PM

Previous topic - Next topic


Hi, did an sparky 4.0 XFCE install on some old machines. One of them has a Broadcom BCM4401-B0  (as identified by "hardinfo")
Ethernet does not start on boot or session start, an usb wifi adapter works on plugin just plug and play.
After doing some research (me = noob) I found out that the command modprobe b44 starts the ethernet interface and connects to internet OK.

Two questions:
1- How can I get ehternet to start by its own????
2- If not possible, can the modprobe command be run at login automatically? If so, how?



Solved my self, bah, google is your friend  8) :

Apparently, installing the new wlan drivers blacklisted the ethernet drivers.

I opened the file /etc/modprobe.d/broadcom-sta-common.conf and commented out the line blacklisting the ethernet adapter (which was b44 by the way).

The file now looks like this:

# wl module from Broadcom conflicts with ssb 
# We must blacklist the following modules: 
#blacklist b44      <--Commented out this line
blacklist b43legacy 
blacklist b43 
blacklist ssb 
install wl /sbin/modprobe --ignore-install wl $CMDLINE_OPTS 


View the most recent posts on the forum