Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

sparky 4.0 lxqt 64 bit install problems in virtualbox [SOLVED]

Started by ElQuia, June 29, 2015, 06:53:36 PM

Previous topic - Next topic

ElQuia

Hi. VirtualBox 4.3.12 on win7x64, previous installation of sparty razor works OK in this setup.

Created new VB for lxqt 64bits. booted live cd, ran install, on installation finish went for reboot,  froze on shutdown, reseted VM, started ok to login prompt, after login, NO GRAPHIC elements, no panels, no icons, changed right clic menu to wm, woked, but STILL NO panels, etc.
Rebooted in recover mode, did apt-get update and upgrade, went well
Rebooted, NADA, still no panels
Installed 5.0 RC1 version of Guest additions instead of navtive ones.
NADA, still no panels.

Ideas please??

pavroo

It looks like a problem during copying files by the installer.
What you can do is:
- install it again
- install it again using the old installer (it's in the menu-> system)
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

Will Try, BUT:

just booted live cd in a "test" VM, the live LXQT media on start shows ONLY the installer icon  and the "sparky online.."  icon on the desktop, NO PANELS, (there is NO "Menu")
the live LXDE media shows both before mentioned icons,  PLUS conky (or something like that)widget and it DOES show the usual sparky panels, menu, system tray etc

Could post screen capture of both, but can´t find a way to upload images to forum ???

ElQuia

OK, did install using old installer.  SAME result: panels ARE down there (lxqt), just sort of invisible, if I click on where the menu should be, menu opens. but low border panels are just a shade different from the background color. No widgets or icons on desktop once installed.

Any way of uploading caputrees (jpg)?

pavroo

Looks like your sparky's lxqt iso image is broken.
Have you checked the md5 or sha sums?
I suggest to download it again using a download manager or bittorent client.
The live system starts with everything ready.

There is no option to uplad images.
Upload it to a free pictures service and link it here.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

There must be some other problem or interaction with virtual box and lxqt. i586 LXQT live has the SAME problem, LXDE both 64bit and 586 DO NOT have the problem

re downloading both LXQT, torrent this time, just in case, will do clean install again.

BTW, upgrade from sparky RC KDE to final on a Dell Studio notebook went Verrryyyyyy smothly  ;)

ElQuia

OK, same history, dowloaded fresh isos,  new VM, booting live cd/dvd

LXQT

LXDE

pavroo

Try to reload the panel:
killall -9 lxqt-panel &
If doesn't start itself, run it again:
lxqt-panel &

p.s.
Use "Insert Image" button to put image link next time as I did with your screenshots.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

OK, on live media it works (killall -9 lxqt-panel &) it restarts itself.

How do I get it to work on an installation?


pavroo

Create a file, for example in your home directory, called 'panel-reload'.
Past it to the file:
#!/bin/bash

sleep 6s && killall -9 lxqt-panel &

Save the file and give execute rights to the file:
chmod +x panel-reload
Make sure to open a terminal it the folder where the file is located.

Open from menu LXQt System Settings-> Session Settings-> Autostart-> Add
Give a name, for example "Panel Reloader"
Command -> choose the 'panel-reload' file just created.
Then relogin to try it out.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

ok, will try tomorrow, do a fresh install and try.

I guess this is a workaround until some final fix is available?

Will be back, thanks ;)

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ElQuia

Nothing to fix? How is that? Is that not a bug?  :o

(doing lxqt fresh install now, will be back)

ElQuia

OK, panel reload trick works. Doing system upgrade now, before installing VBox Guest Additions 5.0 and other apps

ElQuia

OK, back to cero after sysupgrade





killall -9 lxqt-panel & DOES NOT WORK, and the panel-reload autostart that is in place does'nt either....

No other third party software installed, no Virtual Box external addittions, just sysupgrade

Ideas Please ???

View the most recent posts on the forum